Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need to down load the newest version for a mac X and then make it work. I keep getting the message on my original Firefox that it is no longer protected against attacks. I've tried to download 4 but it tells me my computer is not compatable for it.

  • 2 replies
  • 5 have this problem
  • Last reply by ajmilot

more options

It is an older computer purchased in 2003. What would be the newest version of Firefox that a mac mosX could run?

All Replies (2)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

If you have OS X 10.3.9 or earlier, the last version of Firefox that works on that version is Firefox 2.0.0.20 available from https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/

If you have OS X 10.4 or 10.5, there is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

For OS X 10.4 or 10.5, if you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

more options

Thank you. It solved my problem.