Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SSL Error 61: chosen not to trust security certificate; How to bypass?

  • 3 replies
  • 36 have this problem
  • 7017 views
  • Last reply by cor-el

more options

I am trying to utilize Citrix XenApp to remotely access my work userid and applications from home. I can login and see my virtual desktop/applications, but when I try to run an application I get SSL Error 61: you have chosen not to trust "Equifax Secure Global eBusiness CA-1" the issuer of the server's security certificate. I have tried to update the certificate (FFx says its valid), add an exception (cannot because certif is valid), uninstall/reinstall application (no good), but still no luck. Have contacted my company's IT and they are baffled as well. Any ideas to bypass or redo a setting that says I do trust this certificate would be welcome.

All Replies (3)

more options

You need to add that (root) certificate to the Citrix database.

Modified by cor-el

more options

Pardon my ignorance, but can you please explain further. I've read over the info from the link provided but it is beyond my technical comprehension. Is the Citrix database on my end, on my company server's end?

more options

I'm not not familiar with Citrix, but you have a Citrix ICA Client Plugin (Win32) installed. So I assume that you have a Citrix client running or your computer that has certificates installed and you need to check there or contact Citrix or your company for instructions. Also make sure that the date and time on your computer is correct.