Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Message tells me my version no longer protected. Download gives message corrupt image, Using Mac OS10.3.9. Don't want to upgrade as then can't use Classic.

  • 1 reply
  • 4 have this problem
  • Last reply by TonyE

more options

Firefox gives message that my version is no longer protected and that I should install the latest version. However when I do this I get the message that the image is corrupt. Perhaps this is because I am using Mac OS 10.3.9. However, I do not want to upgrade the system as I will lose the ability to run Mac Classic. Is there a version of Firefox that I can run that will still be protected.

All Replies (1)

more options

The message on the default home page is automatic to anybody running old versions of Firefox. As you have OS X 10.3.9 you will not be able to upgrade as Firefox 2.0.0.20 was the last version that works on OS X 10.3.9

You will get the corrupt image message if you try to install a later version.