Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Your browser needs some changes to work with TurboTa

  • No replies
  • 27 have this problem
  • 4 views
more options

I am trying ti use TurboTax through my bank but I get the following: The browser you are using is incompatible with TurboTax. TurboTax supports the latest versions of Internet Explorer, Firefox, and Safari, which can be downloaded from each company's respective website. Please access TurboTax from one of these supported browsers.

I upgraded to 3.6.13 but that did not work either. Any solutions

I am trying ti use TurboTax through my bank but I get the following: The browser you are using is incompatible with TurboTax. TurboTax supports the latest versions of Internet Explorer, Firefox, and Safari, which can be downloaded from each company's respective website. Please access TurboTax from one of these supported browsers. I upgraded to 3.6.13 but that did not work either. Any solutions