Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to install various add-ons, I get "This add-on requires Firefox xx. You are currently using Firefox 3.0.15.", even thou I upgraded to 3.6.13.. Same with FF4.0b7, the add-ons page still sees I have 3.0.15 [SOLVED]

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

Same goes with the recenlty installed 4.0b7, the add-ons page still sees I have 3.0.15. Even now, when I'm typing, the 'educated guess' about my version is still 3.0.15. In troubleshooting info, you will see version 4.07b...

Modified by cor-el

All Replies (2)

more options

After I submitted the question, I found the instructions for reseting my user agent here https://support.mozilla.com/en-US/kb/Websites%20or%20add-ons%20incorrectly%20report%20incompatible%20browser. This solved the problem. Thank anyway! :)

more options

For the record, you have a general.useragent.override setting showing in your More system details list.

general.useragent.override: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15

Using that pref to change the user agent (and forgetting about it) can cause such issues. You may have had an extension installed to spoof the user agent.