Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After I downloaded an update to Version 3.6.11 a couple of days ago, the location bar autocomplete function stopped working, and I can't figure out how to turn it back on.

  • 9 replies
  • 55 have this problem
  • Last reply by pkoi

more options

After the update, when I start typing into the location bar, no prior urls pop up - I have to input all over again each time. This applies not only to locations from before the update, but to urls I have input since then - the location bar autocomplete doesn't seem to be functioning at all. If there's a simple way to turn it back on, I haven't found it. NOTE: Under the "Privacy" tab in Preferences, I have selected: "When using the location bar, suggest: History and Bookmarks."

All Replies (9)

more options
more options

Same problem here. I have Firefox on several machines and OS (XP and Ubuntu [edit: Win 7 too]). However, the bookmarks file is the same in each.

None of the location bars suggest (autocomplete) features work now. I tried deleting the places.sqlite (bookmarks) file and the bar began working again, but all my bookmarks had lost their "favicons". When I replaced that places.sqlite file with my original (including the favicons) the location bar again ceased working.

I highly doubt that the upgrade to 3.6.11 would corrupt every places.sqlite file I have on multiple computers. That leads me to believe that there is some kind of bug in 3.6.11 that messes up the location bar (especially if your bookmarks contain favicons). Hope some kind of patch can be found.

Edit: Just updated Firefox on Windows 7 with same results. I even backed up the places.sqlite (so it could not be corrupted) file before updating then used the backup file when the location bar failed to work. Even restoring with the backup file didn't work - again, this can not be due to a corruption issue.

Finally, I noticed that one (only one) of the autocomplete bookmarks I had selected prior to updating FF in Ubuntu was actually retained. Is there some other file where autocomplete data is held? I wish I knew why that one bookmark is still able autocomplete while all the others will not (note: this is only in the Ubuntu install all other FF installs (in XP/Win7) bookmarks will not autocomplete.

Modified by xtend

more options

If you use the same places.sqlite file in all profiles and that file isn't working then it doesn't seem like a surprise to me that you have problems. If SQLite gets updated to a new version (don't know if that happened) then all SQLite databases need to be updated and that can always cause problems. If you use such an upgraded database with older or different Firefox versions then expect problems to lie ahead.

more options

I don't think that would be the issue as I didn't "restore" the places.sqlite file after each upgrade. I allowed the upgrades to run which should have also upgraded the file to a new sqlite version (if that did, indeed occur). The only time I have tried to use a backup copy of the file was as described above (just as a test to see if the upgrade was corrupting the file).

Modified by xtend

more options

I guess, if it comes down to it, I'll have to suck it up and delete the file, let ff restore it and go to each bookmark site (ugh.) to restore the favicons (not a huge deal but I would prefer to figure out what is going on to cause the problem and avoid it in the future).

more options

I just checked the 3.6.11 release notes and it includes the following:

583611 nor -- All sdwilsh RESO FIXE Upgrade to SQLite 3.7.1

Thus, yes, sqlite was upgraded but, as noted, the upgrade should have upgraded the bookmarks file (places.sqlite) as well, I assume. Could it be that the new sqlite version conflicts with something in the bookmarks file that messes up the suggest feature?

It would be nice to figure out the problem, as I am not the only one experiencing this issue.

Modified by xtend

more options

There have been issues reported with the SQLite 3.7.1 version. Maybe yours is one of them.

See Bug 595530 – Searching bookmarks and history is much slower after SQLite 3.7.x upgrade

(please do not comment in bug reports)

more options

Thanks, cor-el!

I tried exporting my bookmarks (in html) and importing them back in (then deleting the old bookmarks). For some reason, that worked in my Ubuntu FF but in Windows XP, it worked until I restarted FF - then the suggest function failed again. I ended up just deleting the places.sqlite file, allowing FF to restore it and going to the websites to restore their favicon. That held and everything works for now. Not really a good solution for people with oodles of bookmarks (for them, I suggest the re-import of html bookmarks I tried at first...and hope it works).

One last note to ponder: I realized I had a separate FF profile on one computer. I opened that profile and found that everything worked just fine, but it has far fewer bookmarks than places.sqlite file common to all other profiles with the problem. The common places.sqlite file size is: 424 KB while the smaller profile is: 248 KB.

Either the new SQLite version just has trouble with larger files or there was just something in the larger file that caused a conflict. The 'fixed' common file I have now after restoring the favicons was about 454 KB but I compacted it with CCleaner to 400 KB. Since the size is similar to the original (problem) file, it looks more like a conflict issue than a size issue.

Modified by xtend

more options

same problem here !

My profile.sqlite has no problem when being location bar searched by FF 3.6.3

Please fix this.

Modified by pkoi