Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When browsing the add-ons offered on mozilla.com many say "not compatible with Firefox 3.0.2" even though I have 3.6.8; How do I get the add-ons page to recognize that I have a newer version of FF?

  • 1 reply
  • 1 has this problem
  • Last reply by cor-el

more options

When browsing the add-ons offered on mozilla.com many say "not compatible with Firefox 3.0.2" and will not let me install even though when checking the version using the "About Mozilla Firefox" in the Help menu it says I have 3.6.8; How do I get the add-ons page to recognize that I have a newer version of FF?

All Replies (1)

more options

You have a corrupted Firefox 3.6.8 user agent; Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.0.2 GTB7.1 (.NET CLR 3.5.30729)

See Find what version of Firefox you are using and Web sites or add-ons incorrectly report incompatible browser

See also http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

Check the general.useragent prefs on the about:config page.

You can open the about:config page via the location bar, just like you open a website. Filter: general.useragent

If any general.useragent prefs are bold (user set) then right-click that pref and choose Reset.