Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot change "number of results" on Google Search preferences; it stays fixed at 10, why?

  • 7 replies
  • 56 have this problem
  • 363 views
  • Last reply by cor-el

more options

Running 3.6 on Windows 7. I have deleted all cookies, deleted preferences.js, and do not know what else to do. This has been the status for about a week now. The only thing I can think of that I have installed at around the same time is Microsoft Security Essentials, but disabling its real-time protection did not change the behavior. It may be a system issue, since I have the same problem with Chrome and IE 8! I use ZoneAlarm, Symantec Endpoint Protection 11, Spybot as well, but I'm not sure how those would affect this particular setting. Thanks in advance.

Modified by gcat8888

Chosen solution

That is caused by a recent change on the Google site and the addition of Instant search.

If Instant search is enabled on the Google Search settings page (link at the top right) then you only get 10 results.
You need to disable instant search and reload the result page and then set the number of results to your preferred choice.
It may not work if you make both changes at the same time.

Read this answer in context 👍 8

All Replies (7)

more options

Same problem with Chrome and IE 8!

more options

Chosen Solution

That is caused by a recent change on the Google site and the addition of Instant search.

If Instant search is enabled on the Google Search settings page (link at the top right) then you only get 10 results.
You need to disable instant search and reload the result page and then set the number of results to your preferred choice.
It may not work if you make both changes at the same time.

more options

I have the same problem, but Google is refusing to turn off Instant Search.

I've tried to turn it off multiple times, but no joy whatsoever. I tried clearing all cookies and re-logging into my Google account, and disabled all Google-related Firefox extensions, but nothing is working.

Every time I turn it off and save my preferences, Instant Search turns itself right back on! Anyone have a solution for this?

Thanks :)

more options
  • Such details are stored in a cookie.
  • You must allow that cookie (Tools > Options > Privacy > Cookies: Exceptions), especially if you let cookies expire when Firefox closes
  • Make sure that you do not use Delete browsing, search and download history on Firefox to clear the "Cookies" and the "Site Preferences"


See also http://kb.mozillazine.org/Cookies

more options

I have the same problem: Google won't turn off instant search so only 10 search results will show. I've enabled all cookies, but that doesn't help.

more options

Did you try to clear the Google cookies?