X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't maximize in windows 7

kf
Posted

Since the windows 7 update 3 days ago, Firefox will not display. It opens and connects but when I click on the bottom menu bar to actually use Firefox, it will not maximize. I've rebooted. I've uninstalled Firefox and reinstalled. What is going on? All my other browsers work! (None of my other browsers have the many add-ons I like in Firefox, sigh.)

Since the windows 7 update 3 days ago, Firefox will not display. It opens and connects but when I click on the bottom menu bar to actually use Firefox, it will not maximize. I've rebooted. I've uninstalled Firefox and reinstalled. What is going on? All my other browsers work! (None of my other browsers have the many add-ons I like in Firefox, sigh.)

Additional System Details

This happened

Every time Firefox opened

This started when...

windows 7 updated 3 days ago and every day since.

Installed Plug-ins

adblock, image host grabber, down them all.

Application

  • User Agent:

More Information

Morbus 135 solutions 2340 answers

Hopefully this support article is what you need:

https://support.mozilla.com/en-US/kb/Firefox+will+not+start

In any case, it's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

Hopefully this support article is what you need: https://support.mozilla.com/en-US/kb/Firefox+will+not+start In any case, it's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal? Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in [http://support.mozilla.com/en-US/kb/Safe+Mode safe mode] (don't forget to select ''Disable all add-ons'' when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See [http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes this article] for information about troubleshooting extensions and themes and [https://support.mozilla.com/en-US/kb/Troubleshooting+plugins this one] for plugins. If you need support for one of your add-ons, you'll have to contact its author. If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.
Fifi331 0 solutions 1 answers

I had the same thing happen. It just disappeared to the right.

It's not FF, it's your screen. Go to:

control panel screen resolution where it says: "multiple displays" select "show desktop only on 1"

That did the trick for me.

I had the same thing happen. It just disappeared to the right. It's not FF, it's your screen. Go to: control panel screen resolution where it says: "multiple displays" select "show desktop only on 1" That did the trick for me.
ruijorgerodrigues 0 solutions 1 answers

Okay, it's simple to solve! On the image that appear in the task bar when you move the mouse over the icon (firefox in minimized mode) right click and choose maximize. And it's done....

Bye bye...

Okay, it's simple to solve! On the image that appear in the task bar when you move the mouse over the icon (firefox in minimized mode) right click and choose maximize. And it's done.... Bye bye...
Tareq Ashour 0 solutions 1 answers

How to disable to un-install add-ons if you cannot open or maximize the FF window? Is there a way to do that? I'm afraid you lost me somewhere.

How to disable to un-install add-ons if you cannot open or maximize the FF window? Is there a way to do that? I'm afraid you lost me somewhere.
cor-el
  • Top 10 Contributor
  • Moderator
17867 solutions 161689 answers

Helpful Reply

Use Restore or Maximize in the right-click context menu of the Taskbar icon to set focus to the Firefox application if you do not see it.

Open the system menu via Alt+Space and see if you can resize that window.

If that works then close Firefox (File > Exit/Quit) to save that setting.

See also:

If the above didn't help then see:

Use Restore or Maximize in the right-click context menu of the Taskbar icon to set focus to the Firefox application if you do not see it. Open the system menu via Alt+Space and see if you can resize that window. If that works then close Firefox (File > Exit/Quit) to save that setting. See also: * http://kb.mozillazine.org/Resizing_oversize_window If the above didn't help then see: *http://kb.mozillazine.org/Corrupt_localstore.rdf
silvergrrl 0 solutions 2 answers

This just started happening to me. Version 13 worked, with all my add-ins, for a while. then this problem - window stopped maximizing. I happened to have an old download for version 10, so I installed it and it worked! So I tried upgrading again to v 13, and again it worked for a while. Then the problem recurred.So that's what I've been doing for a couple of days now when this happens - go back to version 10, which so far is fine every time, then upgrade back to 13... I hope there's a fix soon.

This just started happening to me. Version 13 worked, with all my add-ins, for a while. then this problem - window stopped maximizing. I happened to have an old download for version 10, so I installed it and it worked! So I tried upgrading again to v 13, and again it worked for a while. Then the problem recurred.So that's what I've been doing for a couple of days now when this happens - go back to version 10, which so far is fine every time, then upgrade back to 13... I hope there's a fix soon.
silvergrrl 0 solutions 2 answers

I just read that part about the localstore.rdf. I've saved my (currently working) file off, and the next time this happens, I'll try it.

I just read that part about the localstore.rdf. I've saved my (currently working) file off, and the next time this happens, I'll try it.