X
Tap here to go to the mobile version of the site.

Support Forum

Images on Amazon won't show

Posted

I tried downloading the latest version of Skype for Mac. On the installation window there was no option to "Upgrade Skype Extension for Firefox". Images on several websites such as Amazon won't show.

This happened

Every time Firefox opened

== When I installed Firefox

I tried downloading the latest version of Skype for Mac. On the installation window there was no option to "Upgrade Skype Extension for Firefox". Images on several websites such as Amazon won't show. == This happened == Every time Firefox opened == When I installed Firefox

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Safe mode start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit") --- Check the image exceptions: Tools > Options > Content: Load Images: Exceptions See Fix problems that cause images to not show and http://kb.mozillazine.org/Images_or_animations_do_not_load

A way to see which images are blocked is to click the favicon (Site Identification icon) on the left side of the location bar and click the "More Information" button. This will open the Security tab of the Page Info window (also accessible via Tools > Page Info). Go to the Media tab of that Page Info window. Select the first image and scroll down though the list with the Down arrow. If an image is grayed and there is a check-mark in the box Block Images from... then remove that mark to unblock the images from that domain.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071505000006
  • iPhoto6
  • Coupons Inc Bricks Safari Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Pando Web Installer
  • 3.0.50106.0
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

The image cannot be displayed because it contains errors
Actions
* Edit this page
* Translate this page
If you receive the message The image cannot be displayed because it contains errors when trying to view images (JPG, GIF, PNG, and more), follow the instructions below.
* If you are having a problem viewing images, but do not get an error message, see Images or animations do not show.
Although it is not the only cause, this problem can be caused by a previous version of the Skype extension.
You can solve the problem by downloading the latest version of Skype from Skype.com. Make sure that when you install Skype, you click on the Option button down to the left of the first installation wizard screen. There you will see the option to Upgrade Skype extension for Firefox. Please make sure that that option is indeed checked.

cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Safe mode start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit") --- Check the image exceptions: Tools > Options > Content: Load Images: Exceptions See Fix problems that cause images to not show and http://kb.mozillazine.org/Images_or_animations_do_not_load

A way to see which images are blocked is to click the favicon (Site Identification icon) on the left side of the location bar and click the "More Information" button. This will open the Security tab of the Page Info window (also accessible via Tools > Page Info). Go to the Media tab of that Page Info window. Select the first image and scroll down though the list with the Down arrow. If an image is grayed and there is a check-mark in the box Block Images from... then remove that mark to unblock the images from that domain.

Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the ''Safe mode'' start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit") --- Check the image exceptions: Tools > Options > Content: Load Images: Exceptions See [[Images or animations do not show]] and http://kb.mozillazine.org/Images_or_animations_do_not_load A way to see which images are blocked is to click the favicon (''Site Identification'' icon) on the left side of the location bar and click the "More Information" button. This will open the Security tab of the ''Page Info'' window (also accessible via Tools > Page Info). Go to the ''Media'' tab of that Page Info window. Select the first image and scroll down though the list with the Down arrow. If an image is grayed and there is a check-mark in the box ''Block Images from...'' then remove that mark to unblock the images from that domain.
northerntrials 0 solutions 1 answers

I started in safe mode with all plugins disabled and Firefox setting back to default. I still can't see the Amazon links on my blog... Is there a way to go back to an older version of Firefox? The links worked fine before my Firefox update. the links still show fine in Chrome and IE. It is not a problem with my site.

Problem started after Firefox updated my version 11. I have tried both 12 and now 13... same problems. Can I go back to 10?

I started in safe mode with all plugins disabled and Firefox setting back to default. I still can't see the Amazon links on my blog... Is there a way to go back to an older version of Firefox? The links worked fine before my Firefox update. the links still show fine in Chrome and IE. It is not a problem with my site. Problem started after Firefox updated my version 11. I have tried both 12 and now 13... same problems. Can I go back to 10?

Modified by northerntrials

cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

Do you see the links in the page source if you select that area with the mouse and select View Selection Source in the right-click context menu?

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and disable website fonts as a test.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
Do you see the links in the page source if you select that area with the mouse and select View Selection Source in the right-click context menu? You can use this extension to see which fonts are used for selected text. *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and disable website fonts as a test. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"