Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Entire page turns black before the content appears

  • 7 replies
  • 0 have this problem
  • 19 views
  • Last reply by groundie

more options

Hi, I have noticed this behavior for a while now and it is becoming bothersome now. It seems to happen ONLY upon initial visit to a site, any site. Once the site loads completely, any links from there loads without the black screen.

Of course, I have searched and tried the known remedies: 1) graphics driver. Chrome, Konqueror and other browsers do not exhibit this behavior. 2) FF add-on's disabled. No permanent difference. 3) Hardware acceleration disabled. No permanent difference.

I'm running 103.0.2 (64-bit) on: Operating System: Kubuntu 22.04 KDE Plasma Version: 5.24.4 KDE Frameworks Version: 5.92.0 Qt Version: 5.15.3 Kernel Version: 5.17.5-051705-generic (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-6700 CPU @ 3.40GHz Memory: 23.4 GiB of RAM Graphics Processor: llvmpipe

This is not a deal breaker but should be addressed to make FF more perfect! Best... Hong Son

Hi, I have noticed this behavior for a while now and it is becoming bothersome now. It seems to happen ONLY upon initial visit to a site, any site. Once the site loads completely, any links from there loads without the black screen. Of course, I have searched and tried the known remedies: 1) graphics driver. Chrome, Konqueror and other browsers do not exhibit this behavior. 2) FF add-on's disabled. No permanent difference. 3) Hardware acceleration disabled. No permanent difference. I'm running 103.0.2 (64-bit) on: Operating System: Kubuntu 22.04 KDE Plasma Version: 5.24.4 KDE Frameworks Version: 5.92.0 Qt Version: 5.15.3 Kernel Version: 5.17.5-051705-generic (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-6700 CPU @ 3.40GHz Memory: 23.4 GiB of RAM Graphics Processor: llvmpipe This is not a deal breaker but should be addressed to make FF more perfect! Best... Hong Son

All Replies (7)

more options

Try downloading Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release


Operating System: openSUSE Tumbleweed 20220813 KDE Plasma Version: 5.25.4 KDE Frameworks Version: 5.96.0 Qt Version: 5.15.5 Kernel Version: 5.19.0-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600 Product Name: HP ZBook 17 G2

Modified by jonzn4SUSE

Helpful?

more options

Well, that's where I'm coming from. Had a number of other issues, so decided to take the standard Ubuntu release route. Did a complete purge of FF and installed it from Ubuntu repository. So far, only issue is this black screen which apparently lot of other folks is encountering as well.

It is clearly unique to FF and only occurs when a new tab/window is opened. A developer needs to take a look....

Helpful?

more options

That might be aimed at users that prefer a dark theme and do not want to get a white flash when opening a new tab.

Helpful?

more options

If you experience a black or blank screen on your Windows device, try the following:

To wake the screen, use one of the following keyboard shortcuts: Windows logo key + P or Ctrl + Alt + Del.

For a black screen, use the following keyboard shortcut: Windows logo key + Ctrl + Shift + B.

Greeting, Rachel Gomez

Helpful?

more options

Please read the original post before jumping to a solution. This black screen behavior occurs ONLY when a new tab is opened and very briefly like a flash. Nothing to do with chosen theme. My PC is running Kubuntu and the problem exhibits itself ONLY with Firefox, not with any other browsers.

Helpful?

more options

Did you ever test Firefox from Mozilla?

Helpful?

more options

Yes. That is what I used before. Same behavior. One thing is clear: this black-screen is peculiar only to FF, not Chrome nor Konqueror. Have not tried Vivaldi recently...

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.