Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using HTTP instead of HTTPS

more options

I'm struggling to get Firefox to use `http` instead of `https` when I'm doing development on my laptop. Playing with the `HTTPS-only` in the settings didn't make difference. With enable or not. I tried to add my `localhost` to exception list, but Firefox still tries to use `https.`

I understand the security concern from Firefox team, but if I'm trying to load by typing `http,` I would appreciate if Firefox gave me a benefit of doubt that I know what I'm doing. Maybe I could disable this feature temporarily. Why force `https` on `localhost`?

Please allow us some flexibility.

I'm struggling to get Firefox to use `http` instead of `https` when I'm doing development on my laptop. Playing with the `HTTPS-only` in the settings didn't make difference. With enable or not. I tried to add my `localhost` to exception list, but Firefox still tries to use `https.` I understand the security concern from Firefox team, but if I'm trying to load by typing `http,` I would appreciate if Firefox gave me a benefit of doubt that I know what I'm doing. Maybe I could disable this feature temporarily. Why force `https` on `localhost`? Please allow us some flexibility.

All Replies (3)

more options

Have you read this, I did a search and found similiar:

https://support.mozilla.org/en-US/questions/959914

Helpful?

more options

You can no longer use some domains like .dev locally because its owner (Google) has added this domain to the HSTS preload list and a secure connection is automatically enforced. The ".dev" domain landed on the HSTS preload list in Firefox 59.0b7 and this means that Firefox will automatically try a secure connection to these TLDs.

Helpful?

more options

Marcelo Garcia said

I'm struggling to get Firefox to use `http` instead of `https` when I'm doing development on my laptop. Playing with the `HTTPS-only` in the settings didn't make difference. With enable or not. I tried to add my `localhost` to exception list, but Firefox still tries to use `https.` I understand the security concern from Firefox team, but if I'm trying to load by typing `http,` I would appreciate if Firefox gave me a benefit of doubt that I know what I'm doing. Maybe I could disable this feature temporarily. Why force `https` on `localhost`? Please allow us some flexibility.

I think it was my mistake. I didn't see that inside the php code there was a line forcing the use of `https.` Once I tried to create a simple `hello world.html,` the site worked.

Thank you all for the reply, and sorry for the noise.

Best Regards

mg.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.