Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not displaying attached files

more options

Dear Sirs,

I am using a web app that stores files of many formats: pdf, jpg, xls, etc.

In Internet Explorer when I press the link to the file the file is opened with the application designated in Windows as default.

I think this is called MIME Type.

Firefox does not open the files, it sends the file to the download queue so I need to look for a new window and get into the downloads folder to open the files.

How can I correct this?

Thank You in advance for your kind help.

-Marin Rene

Dear Sirs, I am using a web app that stores files of many formats: pdf, jpg, xls, etc. In Internet Explorer when I press the link to the file the file is opened with the application designated in Windows as default. I think this is called MIME Type. Firefox does not open the files, it sends the file to the download queue so I need to look for a new window and get into the downloads folder to open the files. How can I correct this? Thank You in advance for your kind help. -Marin Rene

All Replies (1)

more options

As you noticed, Firefox 98 changed the standard behavior from "ask what to do" (before) to "save file" (now). After the file is saved, it is added to the Downloads list and by default, the Downloads list drops open for one-click access.

If you prefer the file to be sent to an external application automatically, here's what you can try:

(1) The content-type for those files might already be on the Applications list on the Settings page. This article has the steps for changing an action there:

Manage file types and download actions in Firefox

(2) If the file type you want to manage is not listed there yet, try this first: open the Downloads list, right-click the file, and choose "Always Open Similar Files".

(There is a toolbar button for the downloads list if you don't want to have to open a separate window.)

Firefox then should add that file type to the Applications list with a "Use [default application]" action. You can use the steps in the previously mentioned article to change it to an Always Ask action if you prefer to choose each time.

(3) If the "Always Open Similar Files" menu item is missing for these downloads, the site might be misidentifying the file as generic binary content instead of identifying it as a specific type.

This is harder to work around. I can suggest an add-on if needed.