Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox update to version 91.6.1esr broke my tab bar

  • 2 replies
  • 1 has this problem
  • 39 views
  • Last reply by guyinchbald

more options

I have my tab bar below the other toolbars. I have a userChrome.css to help set things up the way I use them. System is Linux 64-bit.

Just updated Firefox from a few-months-older version to 91.6.1esr from the official repos and my tab bar is now blank. No tabs, no nothing. When I open a "new tab" I just get the new page; the "Back" arrow is greyed out, so it presumably is a net tabsheet. But I have no tab to get back to the previous page, all is blank.

The tab bar is there at the top OK in Troubleshooting Mode. En/dis-abling all my extensions etc. makes no difference in either mode.

Fixes for related issues tend to focus on userChrome.css but none offers a straight code sample to fix this issue. Here is an extract from mine, I have no idea whether any of it is relevant:

#nav-bar { /* main toolbar */
  -moz-box-ordinal-group: 1 !important;
  box-shadow: none !important;
}
#PersonalToolbar { /* bookmarks toolbar */
  -moz-box-ordinal-group: 2 !important;
}
#TabsToolbar { /* tab bar */
  -moz-box-ordinal-group: 3 !important;
  padding-top: 0 !important;
}

/* FIX TO MOVE TAB BAR BELOW TOOLBAR /*

#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {
  -moz-box-ordinal-group: 10 !important;
}

#TabsToolbar {
  -moz-box-ordinal-group: 1000 !important;
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/
}

/* Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
  bottom: var(--tab-min-height) !important;
  padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/
}

/* TABS: height */
*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;
  --tab-min-height: 25px !important; /*adjust or omit to use density*/
}

*|*:root #tabbrowser-tabs {
  --tab-min-width: 80px !important; /*adjust or omit to use default*/
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*omit*/
  background-color: var(--toolbar-bgcolor) !important;
  color: var(--toolbar-color) !important;
}

I have my tab bar below the other toolbars. I have a userChrome.css to help set things up the way I use them. System is Linux 64-bit. Just updated Firefox from a few-months-older version to 91.6.1esr from the official repos and my tab bar is now blank. No tabs, no nothing. When I open a "new tab" I just get the new page; the "Back" arrow is greyed out, so it presumably is a net tabsheet. But I have no tab to get back to the previous page, all is blank. The tab bar is there at the top OK in Troubleshooting Mode. En/dis-abling all my extensions etc. makes no difference in either mode. Fixes for related issues tend to focus on userChrome.css but none offers a straight code sample to fix this issue. Here is an extract from mine, I have no idea whether any of it is relevant: <pre><nowiki>#nav-bar { /* main toolbar */ -moz-box-ordinal-group: 1 !important; box-shadow: none !important; } #PersonalToolbar { /* bookmarks toolbar */ -moz-box-ordinal-group: 2 !important; } #TabsToolbar { /* tab bar */ -moz-box-ordinal-group: 3 !important; padding-top: 0 !important; } /* FIX TO MOVE TAB BAR BELOW TOOLBAR /* #navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) { -moz-box-ordinal-group: 10 !important; } #TabsToolbar { -moz-box-ordinal-group: 1000 !important; display: block !important; position: absolute !important; bottom: 0 !important; width: 100vw !important; } #tabbrowser-tabs { width: 100vw !important; } *|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox { padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/ } /* Firefox 65-73 */ *|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"]) #toolbar-menubar[autohide="true"] ~ #TabsToolbar{ bottom: var(--tab-min-height) !important; padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/ } /* TABS: height */ *|*:root { --tab-toolbar-navbar-overlap: 0px !important; --tab-min-height: 25px !important; /*adjust or omit to use density*/ } *|*:root #tabbrowser-tabs { --tab-min-width: 80px !important; /*adjust or omit to use default*/ } #TabsToolbar { height: var(--tab-min-height) !important; margin-bottom: 1px !important; box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*omit*/ background-color: var(--toolbar-bgcolor) !important; color: var(--toolbar-color) !important; }</nowiki></pre><br>

Modified by cor-el

All Replies (2)

more options

Chosen Solution

Helpful?

more options

Thank you. Works like a dream.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.