Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 97.0 x64 not loading any page

  • 14 replies
  • 3 have this problem
  • 461 views
  • Last reply by James

more options

I'm using Windows 10 and Firefox 97.0 x64. It was working just fine for a long time now, but I shut down my computer and when I turned it back on Firefox would load, but I couldn't navigate to any webpage not could I pull up about:config or anything.

I tried uninstalling it, restarting it, uninstalling Microsoft Visual C++ redistribute 2015 x86 and x64. Nothing worked.

I then installed the x86 version of Firefox and it was able to load pages. Any ideas on how I can get Firefox 64-bit working on my PC again?

To the best of my knowledge I have not added any new extensions any time recently.

I'm using Windows 10 and Firefox 97.0 x64. It was working just fine for a long time now, but I shut down my computer and when I turned it back on Firefox would load, but I couldn't navigate to any webpage not could I pull up about:config or anything. I tried uninstalling it, restarting it, uninstalling Microsoft Visual C++ redistribute 2015 x86 and x64. Nothing worked. I then installed the x86 version of Firefox and it was able to load pages. Any ideas on how I can get Firefox 64-bit working on my PC again? To the best of my knowledge I have not added any new extensions any time recently.

All Replies (14)

more options

Just found [this topic] also opened today. Like them I'm using Webroot and a quick check confirms that disabling it restores functionality of Firefox 64-bit.

But why would the 32-bit version work when the 64-bit doesn't? And why aren't I getting any notifications that webroot is blocking some process in Firefox?

Modified by abishur

more options

Can you check the Windows Event Viewer? There might be messages in the Application log about a conflict (depending on how a process terminates, the Mozilla Crash Reporter may not appear).

more options
more options

I checked the windows event viewer and found no relevant messages. I also checked through the logs of Webroot and found no mention of blocking it or detecting threats. The most I found was an event analysis (something done for any thread) when I launched firefox noting that it read the process. Nothing further is noted about it.

more options

There is a bug open that explains a deadlock situation when a user has Webroot and a recent Windows update; I added a link to this thread (1752466). A mitigation was added to Firefox 98, which just went into beta. Assuming that doesn't cause other problems, hopefully it can get added to a Firefox 97.0.1 release.

more options

I think I'm having the exact same problem both at work and at home. Unfortunately I cannot disable Webroot at work to see what happens. I do note that after trying to open FF and then closing it, there are 4-6 processes still open in the Task Manager and I have to manually end them.

more options

I can confirm that installing the nightly build gets it working again. You can run it alongside your existing firefox installation to get up and run until either v98 is released or they possibly incorporate the fix into the next v97 release.

Link to firefox-98.0a1.en-US.win64.installer.exe removed by moderator. See Mozilla Support rules and guidelines about posting links to executable files. Note: Firefox Developer Edition is now at version 98 and can be installed alongside your regular Firefox release, as a workaround (see the post by jscher2000, below).

Modified by AliceWyman

more options

If anyone wants to try it, Firefox Developer Edition (based on Firefox 98 beta) will install alongside the regular release and use its own profile. https://www.mozilla.org/firefox/developer/

more options

In the bug report, a user posted that another workaround would be to run 64-bit Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

more options

After looking at the posts from today, I just installed the 98.0b2 (64-bit) developer version and on first blush, appears to be working correctly. I've only tried going to a couple websites with success and haven't rebooted the work computer yet to see if the fix survives, but looking good! I will continue to watch the progress of this thread.

more options

abishur said

I can confirm that installing the nightly build gets it working again.

The Nightly development channel builds are more for Devs and Testers and not so much regular Firefox users in mind as it can get checkins and updates twice a day. Things can be unstable or broken until they get fixed, finished or reverted.

more options

jscher2000 said

In the bug report, a user posted that another workaround would be to run 64-bit Firefox 97 in backwards compatibility mode.

I just tried this and yes, it works but it gives a bulky grey boarder around the sides and bottom when in full screen mode. Since the dev version of 98 is working as well, I'll probably use that over the nightly build

more options

Uninstalled the developer version and installed the current beta. So far, it looks to be functional through a reboot.

more options

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations