Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 96.0 stop working not loading any websites

  • 13 replies
  • 6 have this problem
  • 119 views
  • Last reply by SUMOsJR

more options

Hello guys,

I just dont understand what its with Firefox like 10 minutes ago just with no errors or making sompting to it dose not load any websites at all.

No crash errors no nothink, it opens but when i whant to browse anythink its not woorking.

The only think i see on firefox help > about its Checking for updates loading.

I reboolted my pc, router....etc

IE & Chrome works only firefox not.

Anyone have this issue ?

Hello guys, I just dont understand what its with Firefox like 10 minutes ago just with no errors or making sompting to it dose not load any websites at all. No crash errors no nothink, it opens but when i whant to browse anythink its not woorking. The only think i see on firefox help > about its Checking for updates loading. I reboolted my pc, router....etc IE & Chrome works only firefox not. Anyone have this issue ?

All Replies (13)

more options

Forget to mention, i have same problem on all PCs/Laptops not just in mine one.

Helpful?

more options

Same here. Everything was working fine for and now Firefox will not load anything, even local sources such as my web router config page or Synology DSM management.

All other apps working fine so not an issue with network access.

Helpful?

more options

I have same problem, refresh (more troubleshooting options - Refresh Firefox) did not help. I have disabled all add ons. Clear problem with 96.0.

Helpful?

more options

Schnity said

I have same problem, refresh (more troubleshooting options - Refresh Firefox) did not help. I have disabled all add ons. Clear problem with 96.0.

I dont have any addons at all

Helpful?

more options

I have the same problem but using FF 95.0.1

Since this morning, Firefox won't load any pages but Chromium works fine.

The browser seems to use a lot of CPU & memory (to the extent that my laptop goes in turbo mode) and the process won't stop if I close the browser (I have to manually kill it using the system monitor).

Also, I can't troubleshoot since the process won't quit on it's own.

FF: 95.0.1 OS: Ubuntu 21.10 (with Kde)

Helpful?

more options

Disable HTTP3 support by disabling 'network.http.http3.enabled' key in about:config and then restart Firefox. Worked for me.

Helpful?

more options

@hanfred Thanks!

Helpful?

more options

I downgraded to version 94 and it solved the problem for now :(

Helpful?

more options

I have to thank Reddit for this.

Helpful?

more options

I also have this issue. As suggested above I disabled HTTP3 support and it appears to be working now. Will report back if it goes back to hell.

Helpful?

more options

Unchecking everything in 'Firefox Data Collection and Use' under Settings - Privacy&Security did the trick too, http3 could be enabled again after that. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1749908

Helpful?

more options

Hi

I appreciate that you may have done this already, but please can you restart Firefox which should resolve this issue.

Helpful?

more options

Earlier today, Firefox became unresponsive due to a change in defaults by a cloud provider which triggered a Firefox HTTP/3 bug. We disabled the configuration change and confirmed this fixed the issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.