Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are some fonts all messed up?

  • 10 replies
  • 1 has this problem
  • 21 views
  • Last reply by pfbourassa

more options

https://drive.google.com/file/d/1j-RWTilIiqeKjU4PpLClYdpUkvEpzmy3/view?usp=sharing

I didn't change any text settings of purpose, and I'm seeing this across a few different sites. What should I do?

Thank you!

Attached screenshots

All Replies (10)

more options

Can you provide sites and steps to replicate the issue?

Helpful?

more options

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Helpful?

more options

"Allow Web Sites To Choose Their Own" was checked. I don't have uBlock Origin that I know of.

Helpful?

more options

The screenshot is from https://app.elisiapp.com/#/ And I'm using Windows 10

Helpful?

more options

Okay, unchecking "Allow Web Sites To Choose Their Own" fixed the site I screenshot, but now gmail looks weird.

Helpful?

more options

Helpful?

more options

I don't really know how to address " We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts. "

I don't think I downloaded new versions of them, or blocked anything. I've downloaded fonts from Adobe, and one called "Ride" but I didn't... I don't know, do anything weird with them.

Helpful?

more options

This website specifies various Helvetica variants if I check this in the Inspector, so this could an issue with Helvetica fonts.

.jSHaPE {
	font-family: "HelveticaNeue-Light", "Helvetica Neue Light", "Helvetica Neue", Helvetica, Arial, "Lucida Grande", sans-serif;
	color: inherit;
	cursor: pointer;
}

.fNIskD {
	font-family: "HelveticaNeue-Light", "Helvetica Neue Light", "Helvetica Neue", Helvetica, Arial, "Lucida Grande", sans-serif;
	color: rgb(56, 56, 56);
}

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

Cor-el,

I don't see "Rules" on my inspector, but I could change the size of some words, and they still have pieces missing. (Attached)

Can I tell firefox to use a different font for this site? Or like, how do I even fix Helvetica if that's the problem somehow?

Helpful?

more options

Oh, I did install Helvetica Neue to make a facebook mock-up. So... how can I uninstall a font in Windows? Without breaking something else?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.