Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

yahoo took over my firefox web browser

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by jscher2000

more options

I want to use Firefox but Yahoo has taken over as web browser

All Replies (1)

more options

Hi Nick, where is Yahoo showing up now? For example:

(1) At startup or in a new window (Ctrl+N), it takes over as home page (2) When opening a new tab (Ctrl+T) (3) When running a search from the address bar, it has replaced your preferred search engine (4) When running a search on a completely different site, results show up instead on Yahoo

Very often, the problem starts with a new add-on. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, private search, or Yahoo? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

If you are blocked from using the page or the page is blank/empty:

You can re-check the page in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

After cleaning out non-essential extensions:

You may need to clean up home page, new tab, and search settings. These articles should get you to the relevant parts of the Settings page:

Can you regain control of your Firefox experience?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.