Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No Polish characters on some websites

  • 6 replies
  • 1 has this problem
  • 66 views
  • Last reply by jfd36

more options

Hi,

There's a lot of websites where I cannot see Polish / Latin signs (ąęóżćź) etc.. I don't have any addons enables. Also refreshed firefox to default and updated to newest version, nothing helps here. Also don't have any additional keyboards installed.


Thank you for your help.

Paul

Hi, There's a lot of websites where I cannot see Polish / Latin signs (ąęóżćź) etc.. I don't have any addons enables. Also refreshed firefox to default and updated to newest version, nothing helps here. Also don't have any additional keyboards installed. Thank you for your help. Paul
Attached screenshots

Chosen solution

Tak, to znany problem.

Spróbuj przeinstalować czcionkę z tego pliku: https://dl.freefontsfamily.com/download/Helvetica-Font

Read this answer in context 👍 1

All Replies (6)

more options

Hello Paul,

You may be overriding the page fonts in the Preferences dialog.

Edit menu > Preferences > Content In the Fonts & Colors section, click Advanced Check the box for "Allow pages to choose their own fonts" and OK out. Reload, and the icons should appear.

If you have an extension like NoScript (which is prone to breaking a site's CSS and font), disable it and test the site again.

It may also be the site developer's fault for not importing fonts accurately.

If that doesn't work, your OS might not support specific characters.

I apologize if these don't work. Happy browsing!

more options

Hello!

I already checked this option "Allow pages to choose their own fonts" and in this case I cannot see Polish signs. When I unticked the above option, I see all the fonts properly but all webpages have Serif fonts and it's not comfortable to work with this fonts on f.e. on Facebook or GMail.

When I use Chrome everything is fine and all pages have their own font styles.

I want to support Firefox and not Chrome but it's not comfortable for me with this Serif fonts, earlier everything was ok with previous versions of Firefox


Thank you! Paul

more options

Can you save the following code as .html and open it in Firefox?

<html> <body> <p style="font-family: 'Helvetica'">Helvetica: Zażółć gęślą jaźń</p> <p style="font-family:arial">Arial: Zażółć gęślą jaźń</p> <p style="font-family:serif">Serif: Zażółć gęślą jaźń</p> <p style="font-family:Verdana">Verdana: Zażółć gęślą jaźń</p> </body> </html>

more options

Dzięki za odpowiedź!

Wszystko jasne, coś jest nie tak z Helveticą, tylko co? :(

more options

Chosen Solution

Tak, to znany problem.

Spróbuj przeinstalować czcionkę z tego pliku: https://dl.freefontsfamily.com/download/Helvetica-Font

more options

Thanks a lot! Reinstalling helvetica fonts made the day!

Czytałem sporo wątków o tym problemie, ale nigdy nie było nic napisane o Helvetice... Jeszcze raz dzięki serdeczne za rozwiązanie i bezinteresowną pomoc :)