Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Authentication Required - Mozilla Firefox (Ubuntu 20.4.3 ARM64)

  • 3 replies
  • 1 has this problem
  • 38 views
  • Last reply by andmagdo

more options

Hi Team,

I have set the proxy only at /etc/environment, but I do use proxy in only one specific user to run my azure cloud agent in order to use pipeline, however to be able to stablish the agent's connection to the azure's platform I "must" to open a firefox session and input manually the "Authentication Required - Mozilla Firefox" (The proxy moz-proxy), until that moment no problem at all. In a period of 60 minutes after I have rebooted the client my authentication is asked again, it looks like is a cycle, I really need to fix it. The great way is the authentication to remain such as autologin or something similar.

Could you please assist? I is impacting my project.

Thank you very much,

Chosen solution

The window stores the decrypted data in memory, so when Firefox is closed, the decrypted data is lost. To disable the encryption altogether, disabling the password prompt, you need to go to about:preferences#privacy and remove the primary password.

I am guessing the clearing history comment is to try and not clear the password from memory, but that would not work, the clearing history is for site information, not for local information.

Read this answer in context 👍 0

All Replies (3)

more options

Hello,

The Authentication Required window is because of encryption on the passwords.txt file. If you are automatically inputting this, that removes the effectiveness of the encryption. I am not aware of a way to set Firefox to save the password and autologin, but I think that removes the purpose of the encryption in the first place.

Helpful?

more options

Hi andmagdo, thank you...

You are right I agree about the effectiveness of the encryption, when I mentioned I am inputting automatically the login and password only when the Authentication Required windows is called, just once and after that I would like that authentication won't be asked anymore, is that any way to set?

I found something about "Settings for Clearing History" and let only Cache and Form & search history checked, what do you think?

Thank you,

Helpful?

more options

Chosen Solution

The window stores the decrypted data in memory, so when Firefox is closed, the decrypted data is lost. To disable the encryption altogether, disabling the password prompt, you need to go to about:preferences#privacy and remove the primary password.

I am guessing the clearing history comment is to try and not clear the password from memory, but that would not work, the clearing history is for site information, not for local information.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.