On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

time format

  • 17 replies
  • 1 has this problem
  • 189 views
  • Last reply by jonzn4SUSE

more options

How can I change the time in my browser history to 12 hour instead of 24 hour format?

How can I change the time in my browser history to 12 hour instead of 24 hour format?

Chosen solution

I finally found the solution to my problem. It turned out to be a system problem, not Firefox. I had to change the custom value in the dconf editor to 12 hour, then restart. I now have my A.M/P.M. back in the history! Thanks for trying to help though!

Read this answer in context 👍 1

All Replies (17)

more options

Hey there!

Please see the following link below on the solution (from a similar case to yours) :

https://support.mozilla.org/bm/questions/1247616

Hope I helped!

Kind regards,

Bithiah

more options

No, not the same problem. My time is correct, just in 24 hour format instead of 12 hour as I prefer.

more options

I would like to see the issue. Can you post a pic?

more options

From yesterday history showing 24 hour format. I want it to display as 12 hour, showing a.m/p.m., not military time.

more options

Hey there!

So where in Firefox you're getting this 24-hour time?

Thanks!

more options

Browser history

more options

That screenshot is not helpful which is why we are scratching out heads wonder exactly where you are seeing the time. Post a full screenshot and hide the private stuff.d

more options

Browser history is showing 24 hour time format. I want 12 hour format showing A.M./P.M. I don't know how much clearer I can be! When it gets to 12:00 noon, I want it to start showing 1:00 p.m., 2:00 p.m., etc., not 13, 14, 15, etc. This is the only place on my laptop that shows 24 hour format. I have my Linux system set to 12 hour & that works as it should. It's only the BROWSER HISTORY that is wrong.

more options

Much better!!! I never noticed that before. I'm currently in Windows and see the time in 24hour format.

more options

In Win11, changed my system time to 12hr format. Closed Firefox and after reopening the time showing in the 12hr format.

Let me go back to Linux(openSUSE) and see if it works for me.

more options

Can you also download another copy of Firefox and run it from the folder to see what format it shows.

more options

I tried both the current distro version 91.0.1, separate version 91.0.2, and Nightly. They all have the same issue on Linux showing the 24hr format in Browser history. There may be something in about:config that can be changed. Will have to research it or maybe one of the other contributors are aware of it.

more options
more options

Chosen Solution

I finally found the solution to my problem. It turned out to be a system problem, not Firefox. I had to change the custom value in the dconf editor to 12 hour, then restart. I now have my A.M/P.M. back in the history! Thanks for trying to help though!

more options

So when you said it was a system problem did you mean by your computer system preferences or what...?

Thanks!

more options

Linux, Ubuntu, a setting that I didn't know existed till I finally found someone with the same problem after searching dozens of links.

more options

Good work!  :-)) I was thinking about that, but was not aware of how it's done on Ubuntu. Here is what it looks like for me.