Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video screen on all websites lags once in every few seconds

  • 1 reply
  • 1 has this problem
  • 13 views
  • Last reply by FredMcD

more options

When a video is playing, on any website, like YouTube, Facebook, Bilibili, Weibo, etc., for every couple seconds the screen will freeze for around one second while the sound continues at normal speed. This just happened for a few days. I've tried removing all add-ons, closing extra tabs, restarting the computer, and even re-installing Firefox, but none seemed to work. The internet speed is always fine on my end.

I have a two-year-old ASUS U4300F, Windows 10, Intel i5 8th gen, with NVIDIA discrete graphic card, if that helps.

Chosen solution

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.