Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox shows blank white page for all tabs, unusable

  • 5 replies
  • 1 has this problem
  • 38 views
  • Last reply by metalman630

more options

Referencing these threads: 1281774 1307368 1317055 https://support.mozilla.org/en-US/questions/1333680 (I posted a reply to this thread, but I can't view it and the moderator has apparently closed it thinking this problem has gone away)

We can ascertain that NOTHING seems to help this condition. In fact these threads apply to me as Win 7 / 64 bit apply to me. This started probably about 1.5 years ago.

I too have this problem and yes, it is random. BUT once locked in with this condition, it may "get stuck" for another 5 attempts for the same link. BEST Example, I do surveys every Friday and Saturday night. I use my netscape (AOL) email account. At random, while clicking on the survey link the tab will come up blank and no matter what you do, you CANNOT get this tab to do ANYTHING. No reload, no clicking on a new bookmark, no clicking on home, or typing in the address bar and pressing enter on THAT particular tab. How often does it happen? Maybe 12 times a month (during survey time: maybe every other weekend).

One step further on this. My wife's account on the PC actually does this on a DAILY BASIS REPEATEDLY EVERY DAY when she opens FireFox. In her case, it can ONLY be solved by closing and reopening FireFox after waiting like...say...2 minutes after previously opening it? I have tried opening new tabs etc as mentioned above (including the old right clicky trick and using the "Open in new tab" function). Kinda silly when you have like 27 tabs of blankness. Considering it is her account on the Pc, ok, maybe the "refresh" function might work on her? BZZZT! Nope.

Current version. I can attest that a PC at my 2 jobs that both have Win 7 and at least one, if not both, have 64 bit versions and do NOT display this malady. Also, I did re-install FF about 2 years ago for some other problem. I just ran the troubleshooting more...no go. Per this lead, try https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0... and guess what? No such help . Anyone have have something to kill this bug?

Attached screenshots

All Replies (5)

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including personal data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
  • it is important to delete the Firefox program folder to remove all the files and make sure there are no problems with files that were leftover after uninstalling

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then you can create a new profile as a quick test to see if your current profile is causing the problem.


Reinstall Firefox

Helpful?

more options

So...what you are saying is, you DIDN'T READ the aforementioned threads....all been done, why re-hash the SAME false leads that are KNOWN to not work and include more that might cause security breaches and someone suing you?

I will restate the problem, as my title might lead you in the wrong direction, although oddly, my wife's account is just that for the first time you open it and have to close and re-open FireFox to get it to work.

This is NOT a firewall or a lack of service problem...NO ERROR APPEARS (503, 504 etc...). In fact, since I am on a Win 7, that is highly UNLIKELY to be security as the case as I have no recent win updates for MS. My firewall? Never touched it, and if I do, you are likely to be the cause of breaching and hacking to my devices, then, I may not sue you, but anyone who did read your instructions and followed them, probably would. I would just leave that up to AT&T on what's best for the average user.

RE-EXPLANATION: At random, my account will simply get to a point where a tab will not go, no matter what you do with it...If I'm clicking on some link, I might have to re-click the link say 5 times..and finally it will go. The tab WILL APPEAR mind you, its just blank and does nothing and might have an address at the top of the screen. Use that tab to go to AOL from the address bar...nada. Open something from my bookmarks...nada. Sometimes when I try to open something in another tab AFTER this without closing, or EVEN WITH CLOSING the malformed tab, said next tab...may not do anything but appear either.

Thanks for listening. If you need some log, picture, or file, feel free to ask. In fact, it would be REALLY great that if you are in the troubleshooting mode and have the problem, it would log it for you and then I could POST those logged details, but apparently the troubleshooting mode is really for the developers that think that I use too many add-ons and not for a time to LOG the problem in some way. I only use Trend-Micro antivirus add-on and themes.

Helpful?

more options

Thought I'd throw you a bone....I tried the uninstall / re-install and remove the program file folders thing. In fact I "reset" after install. Worked great for 3 hours. Guess what I'm looking at right now?

Helpful?

more options

New bone to throw you. So I tried the new test account / profile (https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles). You are NOT going to like this. See the attached pic. You now have created a NEW MALADY. I'm 2 hours in and have seen one tab be not responsive and 2 with this new malady. This is a tab that at least thinks it is going somewhere (note the site info at the bottom left and the little blob on the tab is shifting back and forth as well as there is an "X" button to "stop" that...and , guess what? Yea, click the X and nothing happens. Also, today i DID NOT use the FireFox "account" log in, so this malady has nothing to do with that.

So, today's helpful harp to you, and anyone else with the same problem, is more information or ideas to what might be happening:

Maybe this is a combination of how WE USERS want to use our FireFox, and others can confirm that they do the same and this could be the problem????

Here's how I set my FireFox up after install...anyone else do the same? First thing! Get my menu bar back up (File, Edit View, History, Bookmarks, Tools, Help - The three slat bar icon menu on the right of the toolbar - Useless and not organized to Windows standard) Next, View and Customize the tool bar: Remove Pocket, remove weird mystery "Flexible Space", add Home, add sidebar control, remove FireFox Account Next, View, Bookmark toolbar, set to NEVER SHOW. Go into settings General / TABS: only set Open Links in tabs.. Leave most others except set FireFox updates to: "Check" from "Automatic" Browsing: remove Search for text, remove Enable Picture in picture, remove last two "Recommends" Go into settings Home / Home: Set Homepage to Custom URL's and https://www.cnn.com/business. FireFox Home Content: Set Shortcuts to 2 or 3 row. Remove Sponsored Shortcuts. Remove Pocket, recent activity, and Snippet. Go into Search: Default Search engine is always Goggle Search Shortcuts: Always remove or turn off the rest of the GARBAGE. Only leave Google and uncheck Bookmarks, Tabs, History Go into Privacy & Security: Leave Standard set, "Only When FireFox is set to block...." Forms and Autofill: Remove "Autofill Credit cards" Logins and Passwords: Always remove the "Ask to save logins and passwords for websites" Permissions: Autoplay is set to block audio and video Firefox Data Collection and use: Always remove Allow FireFox to run studies and always set Allow FireFox to send backlogged crash reports. New tab setting: Aside from above, always dismiss youtube, amazon, twertquer, mybook/spaceplace At some point my antivirus Trend Micro will want to install it's toolbar operator After making a new profile, definitely not a Trend Micro problem. 2 hours after creating new profile, Trend Micro bar not installed yet. Just browsing through my sites to get icons to appear for links in the bookmarks area and logging into passwords sites...I get my first dead tab.

Helpful?

more options

cor-el So what you are saying is, you've got nothing even though there are users on Win 10 that have this problem.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.