Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twilight Zone on steroids

more options

Not sure if this is from you or not, but I keep getting a pop up ad every 30 seconds if not less hitting me up on their program to stop ads and pop ups. In other words in order to get this ad off my back, I am obligated to purchase this program?? Then when I finely clicked on the dam link it offers another link to down load the program for free. Going through the process in hopes to get this to stop I get directed to another page asking for money. No down load. What is it or who is it that writes this madness up and puts it out there to plague everyone until they put money on the table? and you can never talk to a real live flesh and blood person. Just about the time you think it can't get any more insane it does.

Chosen solution

One possibility is that this was caused by an ad in a page you visited. Another possibility is that your Firefox is infected with a rogue add-on.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Note: Some malware-ish add-ons have been reported to blank out the Extensions panel of the Add-ons page. In that case, to access the list, you need to restart in Firefox's Safe/Troubleshoot Mode. Either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Or if Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you get past this annoyance?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

One possibility is that this was caused by an ad in a page you visited. Another possibility is that your Firefox is infected with a rogue add-on.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Note: Some malware-ish add-ons have been reported to blank out the Extensions panel of the Add-ons page. In that case, to access the list, you need to restart in Firefox's Safe/Troubleshoot Mode. Either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Or if Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you get past this annoyance?

Helpful?

more options

P.S. If you clicked on anyone's links, you may want to do a malware scan. Tips in this article: Troubleshoot Firefox issues caused by malware.

Helpful?

more options

Wow! It worked. Went with the shift,ctrl,and a key found the villain and was able to disable it. It has now been over 15 minutes and haven't seen it. Thanks sooooo much. This dam ad was popping up every 10 seconds promoting their product to stop pop ups. What irony if not insanity.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.