Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

change spel language

  • 6 replies
  • 1 has this problem
  • 22 views
  • Last reply by deridder.1

more options

Hi there,

Can't change the spelling correction language, I've added english 5 times, restarted etc. nothing works. Help would be apreciated, thanks

All Replies (6)

more options

It is possible that you confused dictionary with language pack and that you actually do not have a dictionary installed. This is a misunderstanding we regularly see happen. What you see in "Settings -> General -> Language and Appearance" is about the language for the Firefox user interface and for indicating to a website what languages you prefer.

Installed dictionaries appear under "Add-ons -> Dictionaries". Installed languages for the user interface appear under "Add-ons -> Languages".

Note that not all Firefox versions come with a spell check dictionary for licensing reasons. Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.


You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Helpful?

more options

I suddenly don't have the option of switching when I rightclick on languages if a word is spelled incorrect, this happend just few days ago, I added english dictionary multiple times, I just reinstalled firefox but also this did nothing. Very odd that this suddenly happend and I can't get it back

Helpful?

more options

Is that also not possible in this forum ?

Note that a webpage can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker. You can right-click in the text area or input field and use "Inspect" to check in the Inspector if this text area has a spellcheck="false" attribute.

Helpful?

more options

Yes here too. I see the spellcheck= false when inspected, is there a way to change this? I didn't do anything diffrent before, a few days ago this worked just fine

Helpful?

more options

This is a change that the website makes. You can edit this element and change spellcheck="false" to spellcheck= "true" to verify if that makes spell work.

If this is a plain text editor like on this forum then you can use a bookmarklet. Note that the text area must have focus (i.e. shows the cursor) since it works on the active element.

javascript:void(document.activeElement.setAttribute('spellcheck','true'));

A rich text editor might be harder to fix.

javascript:void(document.activeElement.contentDocument.querySelector('*[spellcheck]').setAttribute('spellcheck','true'));

You can create a new bookmark and paste the JavaScript code in its Location field. You can place the bookmark on the Bookmarks Toolbar for easy access.

Helpful?

more options

I edited the spellcheck to true and it did nothing. I don't think the problem lies in html coding. The option to switch languages when right clicking a word just disapeared, I tried everything to get it back but didn't wotk

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.