Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need Firefox to lie to the website and say that Adobe Acrobat 9 is installed

  • 9 replies
  • 1 has this problem
  • 17 views
  • Last reply by cor-el

more options

I am dealing with a government website. All of the government forms are available as PDFs on this website. However if I try to download a form the site looks at the browser description and does not see Adobe Acrobat installed on my system, so it returns a text document telling me to install Adobe Acrobat release 8 or higher. I cannot install Adobe Acrobat because Adobe does not support Linux. I don't need to install Adobe because Firefox, Chrome, and every other browser on the market has builtin support for PDF. How do I customize Firefox to LIE to the website and say that Adobe Acrobat is installed?

All Replies (9)

more options

Sites cannot see what is installed on your system, and there aren't any modern web browsers that have the old Adobe plugin built-in.

If possible, I suggest saving the PDF directly to disk first, then opening it in your preferred form filler afterwards. If you can't right-click > Save Link As, you can change the default action for PDFs to Save File temporarily. This article will get you to the proper part of the settings: View PDF files in Firefox or choose another viewer.

If that doesn't work, Chromium shows its viewer as a plugin, so maybe that would work?

Helpful?

more options

Thank you. Unfortunately I cannot save the PDF because the web site refuses to upload the PDF if it doesn't see Adobe Acrobat release 8 or higher in the user agent string. I have told the Government over and over again for seven years now that the plugin no longer applies because it was never used by anything except Internet Explorer and that I literally cannot install the plugin into a modern browser because they no longer even support the plugin architecture. Plus I am running on Linux and Adobe doesn't support Linux! But when the Guvmint spec'd out the code they needed to support IE, probably because that was the only browser the poor suffering civil servants could use on their 100% Microsoft platforms. They also decided to use some of the fancier features that were added to PDF for forms, which is why they knew they had to install Acrobat 8 or higher to get support for those features. So I NEED my browser to LIE to the site in the user agent string saying that Acrobat release 8 is installed as an addon. Until it does that every time I try to upload a PDF from the Guvmint site I will instead get text instructions to install Acrobat release 8 instead of the PDF. Basically the user agent string these days is mostly a set of lies after all. I have tried with both Firefox and Chrome and neither of them can get the documents. Many large governments and companies do not permit the installation of software into their computers, so many years later their computers are running with exactly the same software they had when they were unboxed. Since all Windows systems came with IE installed that is what they use even though even Microsoft has asked users to upgrade.

Helpful?

more options

I believe you're best off using a suitable add-on extension. For example, Modify Header Value, https://addons.mozilla.org/en-US/firefox/addon/modify-header-value/ , is designed to allow to you send arbitrary HTTP header values when talking to specific sites or URLs. The documentation uses setting User-Agent in the examples. I found it and others by searching for "modify header" on the addons site.

I have not personally evaluated this extension or any of its competitors, but it certainly looks like it was designed by somebody who needed to solve a similar problem.

Helpful?

more options

If this is about plugins then I assume that they check the navigator.plugins object and that returns empty (length is 0), so to make this work you would check what JavaScript is used on the website and if it would be possible to override properties they need.

Helpful?

more options

If the above does not help, is there a public link (no login required) that demonstrates this problem?

Helpful?

more options

Thank you for asking:

http://www.forms.ssb.gov.on.ca/mbs/ssb/forms/ssbforms.nsf/FormDetail?OpenForm&ACT=RDR&TAB=PROFILE&SRCH=&ENV=WWE&TIT=on00089&NO=ON00089E

Just holding the mouse over the links to the PDFs, with either Firefox or Chrome, pops up a message demanding the installation of Adobe Acrobat. If you click on the link instead of the PDF document you get a text document again demanding that you install Adobe Acrobat.

Helpful?

more options

jamescobban said

Thank you for asking: http://www.forms.ssb.gov.on.ca/mbs/ssb/forms/ssbforms.nsf/FormDetail?OpenForm&ACT=RDR&TAB=PROFILE&SRCH=&ENV=WWE&TIT=on00089&NO=ON00089E Just holding the mouse over the links to the PDFs, with either Firefox or Chrome, pops up a message demanding the installation of Adobe Acrobat. If you click on the link instead of the PDF document you get a text document again demanding that you install Adobe Acrobat.

Upon opening some of the forms, I get the following messages. Firefox says: "This PDF document contains forms. The filling of form fields is unsupported." Another viewer says: "This document uses unsupported features (XFA) and might not render properly."

An XFA form is a proprietary Adobe format masquerading as a PDF file. Since you are on Linux, you can try using Foxit Reader as an alternative to open them.

Helpful?

more options

When I click the link, I get the standard PDF download dialog -- Open in Firefox, Open with [choose program, Save File. I'm not sure what you are referring to when you say clicking on the link instead of the document.

Helpful?

more options

Note that support for filling forms in PDF files is behind pdfjs.renderInteractiveForms on the about:config page in Firefox 88.

  • pdfjs.renderInteractiveForms = true

I have a normandy pref that has enabled this feature.

  • app.normandy.startupRolloutPrefs.pdfjs.renderInteractiveForms = true

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.