Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not start in maximized window

more options

Firefox will not remember that I've maximized the window and upon reopening the browser, it must be maximized each time

Chosen solution

I decided to give it a try to see if fingerprinting protection was enabled in the browser, and if turning it off would resolve the screen size issue.

Here is what I did:

Load about: config in the Firefox address bar.

Confirm that you will be careful if the warning message is displayed.

Search for privacy.resistFingerprinting. If the preference is set to True, the extra fingerprinting protection is enabled, if it is set to False, it is disabled.

If True, set it to False and restart Firefox.

The preference was set to True on the system. I changed its status to False and restarted Firefox. Firefox did remember the correct window dimensions this time when I restarted it, and further tests showed that the browser remembered the window dimensions each time I started it.

So, if you run into that issue you may want to check the preference to see if it is responsible for that. It is up to you then to keep the protection enabled and live with the rounded window dimensions, or turn it off and have Firefox remember the right window dimensions each time.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I decided to give it a try to see if fingerprinting protection was enabled in the browser, and if turning it off would resolve the screen size issue.

Here is what I did:

Load about: config in the Firefox address bar.

Confirm that you will be careful if the warning message is displayed.

Search for privacy.resistFingerprinting. If the preference is set to True, the extra fingerprinting protection is enabled, if it is set to False, it is disabled.

If True, set it to False and restart Firefox.

The preference was set to True on the system. I changed its status to False and restarted Firefox. Firefox did remember the correct window dimensions this time when I restarted it, and further tests showed that the browser remembered the window dimensions each time I started it.

So, if you run into that issue you may want to check the preference to see if it is responsible for that. It is up to you then to keep the protection enabled and live with the rounded window dimensions, or turn it off and have Firefox remember the right window dimensions each time.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.