Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

fonts not displaying correctly

  • 3 replies
  • 2 have this problem
  • 18 views
  • Last reply by cor-el

more options

Hi a lot of websites I visit are not displaying the font correctly when using firefox. I have set "Allow Web Sites To Choose Their Own" already in the preferences. See image below for example. It's happening a lot at the moment . I have updated to latest Firefox and Mac OS is latest. Pages are fine when viewed in Chrome. Help please! Cheers- Vince

All Replies (3)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

Also see: https://support.mozilla.org/en-US/search/advanced?q=fonts&language=en-US&product=firefox&sortby_documents=relevance&a=1&w=1

Helpful?

more options

Thanks FredMcD but as stated in my support question, I had already turned on 'Allow Web Sites To Choose Their Own'. My contrast color setting is at never. Please see attached image for the problem I have.

Helpful?

more options

You can check in Font Book for font issues like corrupted and duplicate fonts.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.