Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

78.7.0esr (64-bit) Encrypted SNI not working on my Debian

  • No replies
  • 1 has this problem
  • 3 views
more options

Hi everyone,

I've tested my browser here https://www.cloudflare.com/ssl/encrypted-sni/# and I noticed, that even by having the following settings enabled: - DoH - network.security.esni.enabled true - network.trr.mode 2 (and 3 also tested) - network.trr.uri https://mozilla.cloudflare-dns.com/dns-query I dont get SNI encrypted.

Any idea how I can debug this? I am looking for logs or something, where I can read why Firefox fails on the handshake. The same settings are working on my Windows Host.

I am using Firejail, dnssec-trigger and I have a OPNsense firewall, but even after disabling firejail, dnssec-trigger and disconnecting from OPNsense, it's not working.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.