Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Enterprise Roots" - can't disable

  • 10 replies
  • 1 has this problem
  • 339 views
  • Last reply by cor-el

more options

I am getting a TLS error on Firefox 82.0.3 (64bit) - Win 10 Pro 64 bit Followed instructions on https://support.mozilla.org/en-US/kb/how-disable-enterprise-roots-preference "security.certerrors.mitm.auto_enable_enterprise_roots" is set to disabled but "security.enterprise_roots.enabled" is set to true but is greyed out and I do not have a toggle option to disable it - why and what is the solution ?

Chosen solution

What antivirus software do you use? These usually force their own certificates into Firefox, and this may be what you are experiencing.

Read this answer in context 👍 0

All Replies (10)

more options

Here is a jpg image of the issue

more options

Chosen Solution

What antivirus software do you use? These usually force their own certificates into Firefox, and this may be what you are experiencing.

more options

AVG Free ! What is the solution to the issue ?

more options

You can disable its Web Protection, that should fix it.

more options

I have disabled AVG WEB SHIELD and it makes no difference to "security.enterprise_roots.enabled" - it is still set to TRUE and is greyed out (non disableable)

more options

What if I delete ENTERPRISE completely ? red highlight on image

more options

Hi, make sure that in the Web Shield tab, the entries 'https scanning' and 'QUIC/http3' are deselected. You will now need to remove an entry in the Windows Registry - if you are unfamiliar with this, I would set a restore point first in case you make a mistake so you can roll back: Type regedit into your PCs search box or Run box (Windows key + R). Next in the Registry, navigate through HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\Certificates then select and right click > Delete the entry ImportEnterpriseRoots That will probably do it and the about:config entry security.enterprise_roots.enabled will no longer be greyed out, but if necessary you can also delete \Firefox and \Mozilla. You might have to restart Firefox and your PC.

more options

I can't figure out how to set the Web Shield tab, the entries 'https scanning' and 'QUIC/http3' are deselected

I carried out the removal of registry key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\Certificates procedure and on rebooting - the key mysteriously REAPPEARS !! The about:config entry is still greyed out !

Modified by Weevie123

more options

You might have to temporarily enable the Web Shield, then turn off 'https scanning' and 'QUIC/http3' and disable Web Shield again afterwards.

After changing the Registry, try restarting your PC - don't shutdown and cold start - you must use Restart on Win10, because shutting down is really hibernation!

more options