Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In browser adress bar when I copy web adress in Japanese and copy it remains in Japanes but not anymore

  • 2 replies
  • 1 has this problem
  • 15 views
  • Last reply by cor-el

more options

I have recently noticed when I copied web address which was in Japanese after copying on a note pad or even in the MS outlook email it turned like this %E3%82%B9%E3%. Before it was copied in the same language such as English or Japanese. When I look at the address in the browser it is in Japanese but if I copy and paste it turn in to %E3%82%B9%E3%. What could be the cause? Is it normal. Any guidance/help will be much appreciated.

Thank you in advance.

All Replies (2)

more options

This is absolutely normal. In the actual URL, forbidden characters are stored (proper term escaped), as %##, where ## is the hexadecimal ASCII code, for instance space is %20. Multiple (usually 2-3) consequent codes are used to encode Unicode characters. Firefox and most major browsers will translate these into text whenever possible for your convenience. As not all browsers currently support this translation, they may act strange if you try to open a URL containing these characters. For instance, a space may indicate that the input text is actually a search query. URL parsing may also malfunction if you use special characters, so posting such an encoded URL in a forum, such as "example.com/text that has spaces" will result in only the first part of the URL (before the first space) being recognised. If you want to use Kanji or other characters in hyperlinks, use custom hyperlink text where available and rewrite the characters in there. There is an online converter for this as well. Example: https://ja.wikipedia.org/wiki/メインページ Actually refers to: https://ja.wikipedia.org/wiki/%E3%83%A1%E3%82%A4%E3%83%B3%E3%83%9A%E3%83%BC%E3%82%B8

Helpful?

more options

You can check browser.urlbar.decodeURLsOnCopy on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.