Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can watch videos yet I can't comment, favorite, save for later, access account, etc. on YouTube

  • 11 replies
  • 1 has this problem
  • 43 views
  • Last reply by Hawkeye

more options

I have spent hours, literally, trying to fix this issue by following firefox community help guides yet nothing I've found has solved the problem. I can fully utilize youtube, with similar addons installed , on google chrome and microsoft edge without any problems yet firefox will allow only videos to be watched on youtube - nothing more. When I try to comment it says: Returned error , when click on the (save) button; nothing happens, when i click on my account icon a blank window opens with a circle spinning in the center endlessly - - the extent of functions is limited to, watching videos . I've manually installed Adobe flash, I've tried disabling the polymer function, I've tried the safe mode with my firewall disabled (I made sure that the microsoft firewall did not enable when I disabled Kaspersky), I went into about:config and did all the adjustments... there is quite a number of other things I did over the course of three hours. In the picture I have one picture showing my firewall/addons disabled with firefox in safemode while in the other picture the firewall/addons are enabled. System Information

Attached screenshots

All Replies (11)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

My apologies on the late response, I appreciate the response yet I was extremely miffed when I read the response due to having tried all those methods of solving this problem. I use CCleaner to erase the cache, cookies, and a lot more; the pictures I included are juxtaposed to show safe mode on/off. I've tried the Hardware Acceleration as well; the first thing I did when I installed Firefox was follow the instructions regarding the safemode/hardware acceleration tip then I went to YouTube only to find that YouTube isn't fully functional. I forgot to mention that I used RevoUninstaller to uninstall firefox so the reinstall was fresh.

Modified by omegainitiate

Helpful?

more options

We do not recommend using other programs to clean Firefox because they could corrupt the files. Also, the browser can clean itself.


Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Helpful?

more options

Regarding cleaning firefox, I did not know that - duly noted, thank you. I included some photos of what i did, I'm not sure if mozilla trashed firefox or what; might be time to dump firefox in the trash

Helpful?

more options

At the upper-left of the YouTube page, you will see the 'hamburger' button. Press it.

Helpful?

more options

I can use youtube to some degree with buttons like the 'humburger' button yet I tried reinstalling the OS. I went from build 2404 to 1909 and I still have the same problem - it's definitely mozilla firefox.

Helpful?

more options

I called for more help.

Helpful?

more options

FredMcD, I found something that I thought was interesting. there appears to be a browser out there that uses the firefox shell which is one of the two browsers i am currently using to use youtube and similar sites. It allows me to use youtube flawlessly which leads me to believe that whatever version of firefox this particular browser is using compared to the official mozilla firefox has some differences that is crippling things akin to youtube. i didn't want to mention the browser by name, to avoid trouble, yet if only i had the skills to compare and contrast what is different in the code between the two that is causing the disconnect when using the official firefox

Helpful?

more options

Would that be Waterfox? That is an offshoot of Firefox, but not from Mozilla.

Helpful?

more options

Tor Browser, i didn't know about Waterfox - when i was looking for alternatives i searched for "secure web browsers of 2020"

Helpful?

more options

I have the same problem and logged it also, https://support.mozilla.org/en-US/questions/1313348

I have carried out all the recommended procedures including cookies, cache, etc and restarted Firefox with all Add-ons disabled and it still does not help with the YouTube problem.

You will see that I have tried YouTube using Edge and Chrome and everything works as it should so it is definitely a Firefox issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.