Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons not working/appearing in toolbar

  • 10 replies
  • 1 has this problem
  • 20 views
  • Last reply by cor-el

more options

Hello,

I have three add-ons and none of them are appearing in the tool bar or working. They are enabled and I am not browsing in private or safe mode. Likewise, when I go to the customize page, none of my add-ons' logos appear for me to move.

I have attempted uninstalling/reinstalling the add-ons, but to no avail. There is room on the toolbar. They have been on the toolbar before with previous Firefox versions. I have made sure that Firefox is updated as are the add-ons in question.

Any help would be appreciated.

Chosen solution

Jscher2000 & cor-el,

Thank you for your assistance. I was able to figure it out.

piloti, this is what helped me:

At first, I mistakenly believed that I was not in private browsing mode. In fact, the "Always use private browsing mode" box was checked in the history section. To disable it, go to Options > Privacy & Security > History. Then, select "Firefox will use custom settings for history" and uncheck the "Always use private browsing mode" box.

I hope this helps.

Read this answer in context 👍 0

All Replies (10)

more options

Hi Dan, can you spot them on the "Overflow" menu?

If they are nowhere to be found, have you tried the "Restore Defaults" button at the bottom of the Customize tab to see whether that returns them to the box of buttons?

Helpful?

more options

You can possibly check the Browser Console for possible messages about these add-ons.

Helpful?

more options

Jscher2000,

I did try the "restore defaults" route, but did that did not work either.

Cor-el,

There were error messages in Browser Console, but they don't seem related to the add-ons:

- "Error: Can't find profile directory" - "User is not subscribed to Monitor" - "Error fetching region TypeError: NetworkError when attempting to fetch resource"

Helpful?

more options

Those messages are standard errors that aren't related to issues with Add-ons.

Do the Add-ons work in a new window ?


You can check for problems with the extensions registry files in the profile folder.

Try to to reset the extensions registry and rename extensions.json (extensionsOLD.json) and rename/remove compatibility.ini (compatibilityOLD.ini) in the Firefox profile folder with Firefox closed.

New files will be created when required.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Unfortunately, that did not do the trick.

Helpful?

more options

You're not alone having this issue. I am having exactly the same. I've followed the steps offered to you with the same non-success outcome. Oddly, this is only impacting W10 machine, not my Ubuntu roll out. Very frustrating.

Helpful?

more options

Chosen Solution

Jscher2000 & cor-el,

Thank you for your assistance. I was able to figure it out.

piloti, this is what helped me:

At first, I mistakenly believed that I was not in private browsing mode. In fact, the "Always use private browsing mode" box was checked in the history section. To disable it, go to Options > Privacy & Security > History. Then, select "Firefox will use custom settings for history" and uncheck the "Always use private browsing mode" box.

I hope this helps.

Helpful?

more options

As a footnote, each extension listed on the Add-ons page can be enabled to run in private windows, too. Click the extension's title to show its Details page, then scroll down to "Run in Private Windows" and click Allow.

Helpful?

more options

I had a similar problem with my add-ons no longer showing in my toolbar. I went to the add-ons manager and clicked to disable and then enable each add-on. This returned my add-ons to the toolbar.

Helpful?

more options

^quote: As a footnote, each extension listed on the Add-ons page can be enabled to run in private windows, too.

That is not entirely true, not all extension can run in PB mode like for instance Firefox Multi-Account Containers (containers only work in regular mode).

Not Allowed in Private Windows
This extension does not run while private browsing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.