Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove AMAZON and GOOGLE from firefiox top sites

more options

I have researched this site and elsewhere, and tried everything I can. Is there a way, in firefox 81.0.2 (latest as of this post according to mozilla) to remove amazon and google from the "top sites" suggestions. For every other website, firefox lets you remove them from the list easily, but not with amazon or google. Ive removed it, deleted all history, clicked the dismiss button, the remove button, nothing, its still there. To prove that its an advertisement by firefox, even when I tried editing the link, firefox simply re-added the original one for me (how convenient!). Ive been with firefox almost 2 decades now, but if they are going to force advertising like this than obviously I need to look into other options.

Chosen solution

Hi Andrew, usually if you "Unpin" search shortcuts from the Top Sites section of the Firefox Home/new tab page Firefox remembers that indefinitely, but if, like zombies, they return, undead, then try this method:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste improve and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false

That should automatically clear the next preference in the list, browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned, but if it doesn't:

(4) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned preference to display an editing field, delete its contents, then press Enter or click the blue check mark button to save the change.

Read this answer in context 👍 0

All Replies (3)

more options

Try to click the 3-dots icon of the Top sites section and then select Add Search Engine. There you'll be able to select and deselect every search engine in this section.

Helpful?

more options

Chosen Solution

Hi Andrew, usually if you "Unpin" search shortcuts from the Top Sites section of the Firefox Home/new tab page Firefox remembers that indefinitely, but if, like zombies, they return, undead, then try this method:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste improve and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false

That should automatically clear the next preference in the list, browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned, but if it doesn't:

(4) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned preference to display an editing field, delete its contents, then press Enter or click the blue check mark button to save the change.

Helpful?

more options

Thank you jscher2000! While i disagree with you saying this is unusual (as itwas occuring on all my installations) i will say that worked thanks! Amazon didnt like it and still re added itself a couple times but now that and google are gone :) I really appreciate it, I was really turned off by this forced advertising.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.