Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Font Issue on Mozilla Desktop (Windows)

  • 2 replies
  • 1 has this problem
  • 8 views
  • Last reply by cor-el

more options

Hi, I am web developer on upwork. I am currently working on motorcycle helmet blog site. I created this website in WordPress and I am facing a font issue only on Mozilla Desktop For Windows. So I am using a font family "Poppins" for headings and titles in the website. Google Chrome load the font perfectly on desktop and mobile on each page. But on Mozilla Desktop, on page https://bestmotorcyclehelmets.net/best-bluetooth-motorcycle-helmets/ It does not load the font. Sometimes it loads the font. On mobile version it is working perfectly. I tried re-installing the browser but for first few tries it shows the font than again same problem. I need to make sure this website works fine on each browser so Kindly help me about this. Thank you for your time.

Chosen solution

If you use uBlock Origin make sure not to "block remote fonts".

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (2)

more options

Hello!

I'm sorry, I can't load the website you've linked. Can you please share a screenshot instead?

Modified by DaneQuane

Helpful?

more options

Chosen Solution

If you use uBlock Origin make sure not to "block remote fonts".

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.