Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 79.0 Won't Open Any Page

  • 9 replies
  • 1 has this problem
  • 19 views
  • Last reply by FredMcD

more options

I'm on Linux Mint 19 Cinnamon. Just upgraded to Firefox 79.0

Firefox opens no problem. I start to type in a url and it shows autocompletions like normal, but when I press enter, nothing happens. No processing indicator, just white screen. The same happens for `about` pages like about:config.

If I open a new tab or (private) window, I get the "Firefox has been updated in the background" message with the button to restart. Click it and it restarts in the same state.

I've double checked that when it closes, there are no firefox processes running.

Everything behaves the same if I start it from the command line with "firefox --safe-mode".

When started from the command line there is a slew of this error:

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x390132,name=PContent::Msg_AsyncMessage) Channel error: cannot send/recv

Help?

Chosen solution

OK—no idea what the conflict might have been, but I ran new updates and did another reboot and the repo installation is working again.

Read this answer in context 👍 0

All Replies (9)

more options

Hi shaav1,

I think this may work for you. If it doesn't let me know and I'll give some other suggestions. I am also a Linux Mint user and other Linux distros.

Start Firefox in safe mode. Go to about:config and perform the following:

   browser.tabs.remote.autostart = false
   browser.tabs.remote.autostart.2 = false 

Close Firefox and open normally. Let me know if it works or not.

Helpful?

more options

Are you currently using a version from the repositories of your Linux distribution? Try the Firefox version from the official Mozilla server:

https://www.mozilla.org/en-US/firefox/all/

Helpful?

more options

la3amon said

Go to about:config and perform the following:

Thanks for the recommendation, but I can't open *any* page. Including about:config

Helpful?

more options

Follow FredMcD's advice. If you performed a 'sudo apt-get install firefox', I would remove, purge and autoclean. Then install from the URL FredMcD posted.

Helpful?

more options

FredMcD said

Are you currently using a version from the repositories of your Linux distribution? Try the Firefox version from the official Mozilla server: https://www.mozilla.org/en-US/firefox/all/

Exactly the same. Removed the repo installed firefox. Decompressed the download and ran the executable. Firefox opens, but any url entered does nothing. The only difference is that when opening a new tab it's not brought the foreground—stay in the background and you can't switch to it. Completely mystifying.

Helpful?

more options

la3amon said

Follow FredMcD's advice. If you performed a 'sudo apt-get install firefox', I would remove, purge and autoclean. Then install from the URL FredMcD posted.

replied to FredMcD and more details there, but no change. Same problem...  :[

Helpful?

more options

There are three versions in my repos:

79.0+linuxmint1+tricia (tara) 79.0+build1-0ubuntu0.18.04.1 (bionic-updates) 59.0.2+build1-0ubuntu1 (bionic)

I tried both of the others; the 79.0 was identical; 59.0.2 would start and open a page for about 2seconds before crashing completely.

Helpful?

more options

Chosen Solution

OK—no idea what the conflict might have been, but I ran new updates and did another reboot and the repo installation is working again.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.