Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Recent Firefox upgrade to cloak IP address now causes me to 2-factor authenticate on trusted sites

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by jscher2000

more options

At my workplace, if I am logged into my workplace network, I am supposed to be able to bypass the multi-factor authentication step when visiting secure workplace sites. However, after a recent update of Firefox (several weeks ago), I am asked to multi-factor authenticate at those sites even when I'm logged into my workplace network. (This is not the case in other browsers.) I suspect the change is related to a new security setting that cloaks my IP address. How can I tell Firefox NOT to cloak my IP address when accessing certain sites? I tried turning off the tracker but that didn't work.

All Replies (2)

more options

Firefox does not do anything to hide your IP address. That would be what a VPN does, which is separate from the Firefox browser.

This sounds like maybe it's something to do with Enhanced Tracking Protection (ETP) in Firefox. That feature can sometimes block certain cookies from being saved in Firefox, which can cause this type of issue.

You may want to try adjusting some of the ETP settings to see if disabling it or lowering how strict its rules are will help.

Helpful?

more options

You might also check whether DNS over HTTPS is enabled in case your servers have both internal and external DNS entries: Firefox DNS-over-HTTPS.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.