Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloads almost always fail: '.part could not be saved, because the source file could not be read.'

  • 6 replies
  • 1 has this problem
  • 33 views
  • Last reply by wormmulch

more options

Error message: E:\Users\Sarah\AppData\Local\Temp\xxxxx.xxx.part could not be saved, because the source file could not be read. Try again later, or contact the server administrator.

I do want to mention upfront that this issue is also affecting Chrome and IE. It's not solely a Firefox issue, but I'm hoping someone here can help me anyways.

  • This happens for any filetype, from any source.
  • It started happening about a month ago.
  • Prior to that, I installed a new motherboard, RAM and processor. I'm fairly certain there was a period between these events in which it worked fine, but I am mentioning it just in case it's relevant.
  • If it's a small file and I try repeatedly, it sometimes will eventually download.
  • Even if a large file successfully starts downloading, it will eventually fail. It usually fails immediately though.
  • I sometimes have success downloading the same file in Chrome, but it also often fails. IE as well.

I have tried the following:

  • Used Refresh Firefox
  • Cleared download history
  • Changed download location
  • Reset browser.download values
  • Disabled firewalls and antivirus/spyware
  • Reinstalled Firefox using Run as Admin (first uninstalled previous version and deleted all program files that I could find, including profiles)
  • Cleared cookies and cache
  • Ran in safe mode
  • Verified Temp folder filepath was valid
  • Verified the PART file was created in that path -- it exists until I hit OK on the error message, then it disappears
  • Ran Firefox as admin

I think these are outdated methods I only found on non-official sources, but will mention them just in case:

  • I found some sources that said to delete Compreg.dat; I could not find this file in the place listed, nor could I find it with a search of the entire drive
  • Verified places.sqlite was not set to read-only
  • Removed read-only from entire profile folder and subfolders

In Options > Security: 'Block dangerous & deceptive content': true, 'Block dangerous downloads': false

Internet speed test: 58.96 Mbps download; 148.04 Mbps upload. No connection loss.

This problem is absolutely maddening. I'll be so grateful if anyone can help me out!! :( Thank you in advance, I know this was a long read!

(Edited for readability)

Modified by wormmulch

All Replies (6)

more options

http://kb.mozillazine.org/Issues_with_Firefox#Downloading_opening_or_saving_files

philipp said

hi, is your device/account somehow protected by windows parental controls?

the problem you're seeing is likely
https://bugzilla.mozilla.org/show_bug.cgi?id=1586228
which is currently under investigation...

Also see; https://support.mozilla.org/en-US/kb/unable-download-files-windows-10-parental-controls

Helpful?

more options

Hi there,

Thank you so much for your reply!

No, I would not have set any parental controls, so unless they are on by default, it would not be that. I am the only user on the computer and I am using an administrator account which I imagine would bypass any parental controls anyways. The second article you linked also says that particular bug was fixed in the 69.0.3 release, and I'm running 78.

The Bugzilla report you linked does seem similar to my issue; however, there are some differences:

  • I CAN still download things. It takes many tries, and they have to be small files, but if I get lucky and keep at it, I usually can eventually get it to download.
  • From the look of it, that bug does not display any error message whereas mine does.
  • My downloads typically don't make it to the download panel. I get the error message before I even click save. (If I click save first and it fails afterward, then it does show as failed in the panel, and retrying the download fails repeatedly.)
  • They reported that things download fine in Chrome and Edge. I did not test Edge, but also had the same issue in Chrome and IE (Chrome seems to have a better chance of a successful download than Firefox, though)

The last post in that thread, from Molly, requests the user post their troubleshooting information and check the browser console for any messages. I will do this when I get off work. Maybe it can be of some help.

Also wanted to note that yesterday not long after posting this, I had a period where I actually thought the problem had fixed itself. I was able to download several files with no issues, probably over a 10 minute period. The problem did come back, though. Not sure if I just managed to get extremely lucky there, or if it's actually a problem that's somehow coming and going.

Again, thank you for your response, it is much appreciated!

Helpful?

more options

Helpful?

more options

Troubleshooting info: https://pastebin.com/dJiSbYAk

Browser console log when download failed: https://pastebin.com/scQZwEtc

Browser console log when download succeeded: https://pastebin.com/MgjLWhHk

Helpful?

more options

What security software do you have ?

It is possible that (anti-virus) security software is causing the problem.
Try to disable security software temporarily to see if that makes a difference.

Helpful?

more options

Thanks for the reply cor-el!

I'm using Windows Defender for firewall and antivirus, plus Spybot and Malwarebytes. I have tried closing Spybot and Malwarebytes, turning off my firewalls, and turning off all options in Defender antivirus. No luck.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.