Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Linux, .desktop files, Sites in App Mode

  • 4 replies
  • 1 has this problem
  • 12 views
  • Last reply by Bryan Moore

more options

Hello, all...

I'm running Solus 4.1 with the 5.6.18-155 kernel on my Asus UX330UAR and Firefox Nightly 79.0a1 (2020-06-26) (64-bit). Currently, I used Android Messages for Web via a "webapp" in Brave and am provided a "desktop icon" for that window; however, I'd much rather use my default Firefox and just discovered the "browser.ssb.enabled" setting.

The "trouble" is doing so does not provide any icon to launch by itself; that is, I must be already in Firefox to use the "App Mode."

Any ideas on how to accomplish this dream?

Thanks for any ideas!

All Replies (4)

more options

Chosen Solution

Helpful?

more options

Thanks, @cor-el; frankly, I didn't even think to "rtfm."

Helpful?

more options

You're welcome.

Well, this is a new feature and is still in development.

  • Bug 1407202 - [Meta] Desktop Progressive Web App Support

Helpful?

more options

Also, thank you for that bug link... It would seem ssb really is still rather barebones; funny, one of the issues mentioned three years ago in that bug was the web app won't load unless there is already an instance of Firefox running and that's still the case. One would think three years would've ironed out that little failure...

Again, thanks for the help and patience!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.