Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox MegaBar

  • 16 replies
  • 3 have this problem
  • 80 views
  • Last reply by jscher2000

more options

I don't like the megabar, and I have looked around to see if there are any fixes for the most recent Firefox 77 update that forces that user to have it (like at least one other update, it just assumes that people like it). I have tried using the userChrome.css file, but that didn't work. I have also tried going into about:config, which also didn't work. Is there any possible way to say 'I never want to see this megabar again in my life'? Or a way to tell the devs that it should NOT be a default option on new updates? Or a way to turn it off that will always be around, unlike the about:config deal? Any help would be great. I attached an image of the megabar.

Attached screenshots

All Replies (16)

more options

The windows that are already open keeps the megabar behavior until the next session, even if you have made the changes. You may want to try closing all the windows after applying the changes. Also, please confirm the steps being used, in the process, from this reference thread discussion: https://support.mozilla.org/en-US/questions/1274579#:~:text=(1)%20In%20a%20new%20tab,the%20button%20accepting%20the%20risk.&text=Note%3A%20This%20preference%20does%20not%20exist%20in%20Firefox%2071%2D72.&text=This%20preference%20to%20turn%20off,will%20work%20in%20Firefox%2076.

Helpful?

more options

Hello.

The option to turn off the new Megabar has already been removed from Nightly 77 follow this :-

  1. browser.urlbar.update1
  2. browser.urlbar.update1.view.stripHttps
  3. browser.urlbar.openViewOnFocus

https://bugzilla.mozilla.org/show_bug.cgi?id=1627969 https://bugzilla.mozilla.org/show_bug.cgi?id=1627988 https://bugzilla.mozilla.org/show_bug.cgi?id=1627989

thank you!

Helpful?

more options

Every time I change something, I would close and re-open Firefox, yet the megabar is still there. I have already tried toggling all of those menus, and nothing removes it.

Helpful?

more options

Hi cdr5of8, it's not a "one-stop shop" any more.

Enlargement Effect

You need to use a userChrome.css file to tame the enlargement in Firefox 77+. I'll link to a recent reply with detailed steps and perhaps that will get you over the hump on this point: https://support.mozilla.org/en-US/questions/1289351#answer-1318441

Automatic Opening

If you do not want the Top Sites list to pop down automatically when the cursor moves into the bar, you can still change browser.urlbar.openViewOnFocus to false on the about:config page. Info on that page: Configuration Editor for Firefox.

Show History button

If you want that old list, you can type the ^ character in the bar, or when the bar is empty press the down arrow key (on the keyboard). Alternately, I created an add-on for those who strongly prefer a button: https://addons.mozilla.org/firefox/addon/show-history-top-sites-button/ -- if you try it, let me know any improvements you'd like to see.

Helpful?

more options

I have already tried using userChrome.css. It didn't change it. I followed the instructions here: https://www.userchrome.org/how-create-userchrome-css.html, but it didn't solve the problem.

Helpful?

more options

Hi cdr5of8, which rules did you try in your userChrome.css file? Did you try the ones I linked to?

Helpful?

more options

Yes, that is the one that I tried.

Helpful?

more options

userChrome-ZeroEnlargement.css

Helpful?

more options

Those rules tested out for me, so please review the other steps to make sure everything is set up as needed. Unfortunately, this forum doesn't offer remote assistance so you need to be our eyes and hands.

Helpful?

more options

I have checked all the steps multiple times at this site: https://www.userchrome.org/how-create-userchrome-css.html, yet it still hasn't been fixed. Is there some step that this site is missing?

Helpful?

more options

cdr5of8 said

I have checked all the steps multiple times at this site: https://www.userchrome.org/how-create-userchrome-css.html, yet it still hasn't been fixed. Is there some step that this site is missing?

The one change is for step #5, use the rules file for this specific modification, and make sure to rename it to userChrome.css (delete out the -ZeroEnlargement part).

Helpful?

more options

I tried putting it in a folder called rules in the same place as chrome was, and that didn't work. Did I misunderstand what you were saying?

Helpful?

more options

Sorry I wasn't clear.

You've got a folder named chrome in your profile folder. Firefox will look for a file named userChrome.css in there.

No other folders are needed. No other file or folder names will work.

Can you cross-compare with this post: https://support.mozilla.org/en-US/questions/1289351#answer-1318441

Helpful?

more options

That is the file I had put it in when it didn't do anything.

Helpful?

more options

Hey, jscher2000. I think you're the guy I was talking to over this exact same issue two updates ago.

You seem to know the ins and outs of firefox pretty well. I want contact information for somebody responsible for this. I don't care who. I want to talk to somebody on the team. Do you know anybody?

Helpful?

more options

Hi catnapster, I know a few people in the support world but I do not know people in the area of UI design. You could post on the Mozilla Discourse, for example, https://discourse.mozilla.org/c/firefox-development or something more UI oriented if there is one.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.