Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot play videos except Youtube

  • 4 replies
  • 1 has this problem
  • 2776 views
  • Last reply by Max

more options

Hi Everyone,

Trying my luck here as a last resort. I cannot read videos on FF (I end up with the following message "This video file cannot be played.(Error Code: 102630)") except Youtube ones.

I read few articles and already tried the following: make sure I have the latest version of FF, uncheck "Use hardware acceleration when available", install FFMPEG, install K-Lite (and restart FF each time).

Nothing worked so far so any other tips from the community would be great.

I'm using Windows 10 and have a couple of add-ons only (LastPass and uBlock origin).

Thanks a lot in advance,

Max

Hi Everyone, Trying my luck here as a last resort. I cannot read videos on FF (I end up with the following message "This video file cannot be played.(Error Code: 102630)") except Youtube ones. I read few articles and already tried the following: make sure I have the latest version of FF, uncheck "Use hardware acceleration when available", install FFMPEG, install K-Lite (and restart FF each time). Nothing worked so far so any other tips from the community would be great. I'm using Windows 10 and have a couple of add-ons only (LastPass and uBlock origin). Thanks a lot in advance, Max

All Replies (4)

more options

Hi Max, glad to see you on Mozilla Support Forum.

Maybe some of your file have has been corrupted that's why you are facing this problem. You can fix this issue by refreshing the browser.

  • Click the menu icon, then click on “Help”. Click on Firefox's main menu button, represented by three horizontal lines.
  • Click “Troubleshooting Information”.
  • Click on “Refresh Firefox”.
  • Confirm.
  • Click “Finish”.

If it doesn't solved your problem, then you can freely ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

more options

Hi Shashank,

Thanks a lot for your quick reply.

Just tried what you suggested but unfortunately it doesn't solve the problem...

Any extra information I can submit to help knowing what's happening?

Thanks,

Max

more options

Chosen Solution

more options

Thanks a lot Cor-el, tried a few options from the 2nd link and it turned out Flash Player was the issue. So all good for now, thanks again :)