Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Home Page

  • 17 replies
  • 1 has this problem
  • 28 views
  • Last reply by McCoy

more options

For some reason when I open Firefox it always goes to the last page I had open. I want it to always open to my home page. Hpw do I accomplish this?

All Replies (17)

more options

Go to settings > Home > New Windows and Tabs > choose fromthe settings

Helpful?

more options

This does not help. I already have my homepage set up there.

Helpful?

more options

Hi birdman51, glad to see you on Mozilla Support Forum.

Looks like the browser is always automatically restoring the previous Session. You can turn off this by just following these steps:-

  • First click on menu icon.
  • then, click on options.
  • In general menu, you will see startup option.
  • Uncheck the Restore Previous Session Option.

If it doesn't work, then feel to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Helpful?

more options

How are you exiting Firefox?

There is an actual exit feature hidden in the File menu or you can use {ctrl +shft + Q} from the keyboard to properly exit Firefox.

Helpful?

more options

The restore previous session function is already unchecked. When I exit Firefox I just click on the X in the top right corner.

Helpful?

more options

birdman51 said

This does not help. I already have my homepage set up there.

Hello birdman,

Would you please, just to make sure, check the setting again and go over this page :

How to set the home page

(I noticed that you had your homepage set to   http://www.sympatico.ca/   8 years ago)

Helpful?

more options

birdman51 said

When I exit Firefox I just click on the X in the top right corner.

It could it be that you shut down your laptop or computer too fast after
closing Firefox;   the browser needs some time to properly close.

Helpful?

more options

No I am very careful of that. Besides I do not have to shut my computer down for this to happen. I just shut Firefox down. Do some other work and when I reopen firefox it goes to the last page I had open.

Helpful?

more options

Did you try what I suggested in my penultimate post ?

(can't hurt to check once more .... )

Helpful?

more options

Forgot to ask :

Does your homepage open when you click on the "Home" button ?

Helpful?

more options

Yes it does open when I click on the home page button. Every time.

Helpful?

more options

You can add the homepage URL to the target line in the Firefox desktop shortcut.

Helpful?

more options

If you are talking about setting a custom url I have done that.

Helpful?

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox Title bar to make sure Firefox closes properly and to prevent Session Restore from restoring a session that looks like a crashed session.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Helpful?

more options

See also  the-edmeister's   post.

In case you don't know where to find   "File":   that's on the menu bar, which (if you don't have that permanently enabled)   you can bring up by pressing the Alt key.

Helpful?

more options

I have done these session close options and there is no change.

Helpful?

more options

McCoy said

birdman51 said

This does not help. I already have my homepage set up there.

Would you please, just to make sure, check the setting again and go over this page :

How to set the home page

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.