Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

American Express Site Scripting Issues - won't log on via main page; 10x tries to log-off

  • No replies
  • 1 has this problem
more options

Has anyone else noted issues with AmEx site? Using Win10/FF76, with NoScript 11.0.25 (& previous). NoScript is only extension.

Since AmEx redesigned their website several (many?) months ago, I've had increasing issues using Firefox to log-on the site via their (bookmarked) new log-in page (a bookmarked link to their old log-on page still works, as do all my other banking/financial sites, as well as 98% of other sites). Log-on button reacts when clicked, but no action - doesn't seem to run its script. Initially, allowing permissions multiple cycles using NoScript (as is typical for some sites, as scripts load) was sufficient (I try to reduce scripts to minimum necessary, always excluding Facebook scripts). Logging on via link from AmEx home page sometimes worked slightly better. However, internal site functions seemed to need multiple refreshes on load. Within the last two months, only completely disabling NoScript for AmEx tab worked. Today, not even disabling or uninstalling NoScript completely worked. In addition, today cannot log-out of AmEx site without multiple (~10x) clicks on the log-out button (webpage seems to gradually close down functionality with each click and twirl of the script indicator, similar to functionality loading issue previously noted).

Clearing all cache and cookies (per FF forum help) works one time - log-on can be accomplished with two attempts, but log-out continues problematic. Subsequent log-ons problematic.

As before, problem repeated on other computers (today, two other computers using Win10/FF76; one with a new Win10 and FF install w/o NS).

Previously, other browsers unaffected (Old MS Edge, Opera). Today, using MS Chrome Edge, AmEx site worked without problem. However, noted that AmEx log-on page loaded with Edge was old-style (that still works with FF, also), not new. All SSL certs (FF and Edge) verified.

AmEx doesn't have any link to their Web Support - I guess I have to write them a letter.. Suspect it's a problem on their end, not FF, but have run into several sites lately where FF either doesn't run well, or is specifically not supported. Don't want to give up privacy features and independence of FF, but would like some ammo to hit AmEx with, if it's indeed an engineered problem with their site.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.