Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser will no longer open a new tab when clicking on search results, would like to do this so I don't have to use a differnt browser

  • 3 replies
  • 1 has this problem
  • 1 view
  • Last reply by jscher2000

more options

I often want to keep a tab open and go back to the search. It used to be that clicking on a search result opened a new tab,but now it replaces the search with that link so that I have to back out of it to get to the search and use history to see where I have been. This is a dealbreaker for me. There does not appear to be any way of restoring this behavior, even in about:config. Help

Chosen solution

P.S. Your Firefox reported it is an out-of-date version, Firefox 72. Are you aware of any reason it might not be updating? It looks like it's the build from your distribution's repository and not from Mozilla's site.

Read this answer in context 👍 0

All Replies (3)

more options

John said

There does not appear to be any way of restoring this behavior, even in about:config.

Have you tried this preference :

browser.search.openintab   and set its value to   true  ?

When I want a link to open in a new tab,  I just hold the Ctrl key and then click on the link,   but that's my personal choice.

Helpful?

more options

Hi John, do you mean your results page on Google, DuckDuckGo, Bing, Yahoo, etc., used to send results links to a new tab, but it doesn't any more?

Each search engine has its own setting for this, which is typically remembered by setting a cookie on your browser. Cookies are pretty easy to toss, so you may need to go back to the search engine's settings/preferences page to reselect this option and have it save a new cookie.

If you can't find the setting on the search site, feel free to mention which site it is and perhaps McCoy or I can track it down for you.

And when you do find the answer, please feel free to update this thread with the necessary steps, for the benefit of other users who find your question.

Helpful?

more options

Chosen Solution

P.S. Your Firefox reported it is an out-of-date version, Firefox 72. Are you aware of any reason it might not be updating? It looks like it's the build from your distribution's repository and not from Mozilla's site.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.