Search Support

everytime i clear my cache and cookies i am asked to verify my account..EVERY single time.but this only happens with to stop?

  • 3 replies
  • 1 has this problem
  • Last reply by cor-el

more options

as i said...every single time i clear my cookies and cache in firefox and then go to log onto one particular i ma asked by the site to verify my account...EVERY SINGLE TIME!!..never used to happen before i upgraded firefox and it costs me money in text each time,,ridiculous to go through this each and every time...and seems to only happen with that one how do i stop this from keeping on happening......??..thanks

All Replies (3)

more options

Can you have it verify you with an email instead of a text? When you clear your cookies, you lose your login info, so that's why it's asking you to verify yourself each time.

It is possible to set it to expire all cookies when you exit the session (keeping you from purging manually) and then you can whitelist specific sites to KEEP the cookies so you wouldn't have to verify yourself. Details from here, per cor-el:

The usual method is:

(1) Change the default cookie lifetime from "however long the website wants" to "current session only"

(2) Create exceptions on a site-by-site basis as needed

(3) Do not use any other method of clearing cookies, since the current session only cookies will be culled automatically

For #1:

   Windows: "3-bar" menu button (or Tools menu) > Options
   Mac: "3-bar" menu button (or Firefox menu) > Preferences
   Linux: "3-bar" menu button (or Edit menu) > Preferences
   Any system: type or paste about:preferences into the address bar and press Enter/Return to load it 

In the left column, click Privacy & Security. On the right side, set "Firefox will: Use custom settings for history" and then:

[X] Accept cookies from websites Accept third-party cookies: Always Keep until: I close Firefox [_] Clear history when Firefox closes

For #2:

You can use the Exceptions button on the Options page, but the formatting can be particular. It may be easier to use the Permissions panel of the Page Info dialog while you're on the site that should be allowed to set cookies. You can call that up using either:

   right-click a blank area of the page and choose View Page Info > Permissions
   (menu bar) Tools menu > Page Info > Permissions 

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer (in this case, "Allow").

Changes are saved as you go, so you can close this dialog when you're finished.

For #3:

Make sure "Clear history when Firefox closes" is not checked. Or, if you want to clear cache or other data, click the Settings button to the right and make sure that neither Cookies nor Site Preferences is checked.

   Cookies: does not obey exceptions, removes everything
   Site Preferences: these are your exceptions, don't remove them 

Does that work for you?


more options

thank you for your contact and your trying to help..did not solve the problem..happened again...I have a feeling it has to do with the site..i have contacted them but got no help...oh well..thanks Eve for trying..:)


more options

A detail like a website remembering you (log you in automatically) is stored in a cookie. So if you clear all cookies then you may have to go through additional verification steps.

Best is to clear only cookies from affected websites and not all cookies. Clearing cache is always all or nothing, but you can clear cookies for specific website

You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear all cookies including cookies with an allow exception you may want to keep.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"

You can create an allow exception to keep cookies for specific websites.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Permissions"

You can use these steps to clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.