Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

no longer can open netgear's "routerlogin.net" page I get re-directed to a netgear problem page

  • 1 reply
  • 1 has this problem
  • 9 views
  • Last reply by Eve

more options

Two or three weeks ago I was able to get to my router settings with Firefox. I tried to get to the "routerlogin.net" page yesterday and was redirected to another Netgear page indicating that some web browsers were "caching" the page and that is why I couldn't open the page. I uninstalled and then reinstalled Firefox and it still has the same problem. I tried Microsoft Edge...same problem. Yesterday I installed Google Chrome and was able to easily access my router. I prefer to use Firefox as I have been for several years. How can I fix the problem?

All Replies (1)

more options

try navigating to that page and pressing CONTROL + F5 to bypass the cache if it is indeed caching the page and see if it works then