X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Help wanted: Firefox 73+ background image handling

Posted

A change was introduced in Firefox 73.0 that makes it display background images contained in web pages, even if a Windows High Contrast color theme is in use and even if the "Override the colors specified by the page" option in Firefox is set to "Always." Is there a way to override this behavior and make Firefox suppress background images the way it did in version 72? As a low-vision user, I find that the new behavior interferes a lot with the readability of some web pages, and I haven't come across a page yet where the new behavior actually helps me. Note that I don't want to suppress ALL images, only the background images, the way it works in version 72. For now, I have reverted to version 72 of Firefox, but I don't like that as a permanent solution, since it would mean giving up on all future upgrades to Firefox.

A change was introduced in Firefox 73.0 that makes it display background images contained in web pages, even if a Windows High Contrast color theme is in use and even if the "Override the colors specified by the page" option in Firefox is set to "Always." Is there a way to override this behavior and make Firefox suppress background images the way it did in version 72? As a low-vision user, I find that the new behavior interferes a lot with the readability of some web pages, and I haven't come across a page yet where the new behavior actually helps me. Note that I don't want to suppress ALL images, only the background images, the way it works in version 72. For now, I have reverted to version 72 of Firefox, but I don't like that as a permanent solution, since it would mean giving up on all future upgrades to Firefox.

Chosen solution

Try to set this pref to false on the about:config page.

  • browser.display.permit_backplate = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17857 solutions 161589 answers

Chosen Solution

Try to set this pref to false on the about:config page.

  • browser.display.permit_backplate = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set this pref to false on the <b>about:config</b> page. *browser.display.permit_backplate = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Was this helpful to you? 1
Quote

Question owner

Thank you. That seems to do what I want -- much more to my liking!

Thank you. That seems to do what I want -- much more to my liking!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.