X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Auto-Sync not working on my Android. Path suggested by Firefox non-existent on Android 9 Pie

Posted

On my Huawei Android 9 Pie, the Auto-Sync functionality does not work. Firefox app suggests to toggle auto-sync data (see screenshot) under Settings>Accounts. I cannot find this path, all I can find is Settings>User&Accounts>Firefox. From there, "Configure Sync" only brings me to the screenshot again with the same error message. All I can do here is manually Sync using the "Sync All" button.

On my Huawei Android 9 Pie, the Auto-Sync functionality does not work. Firefox app suggests to toggle auto-sync data (see screenshot) under Settings>Accounts. I cannot find this path, all I can find is Settings>User&Accounts>Firefox. From there, "Configure Sync" only brings me to the screenshot again with the same error message. All I can do here is manually Sync using the "Sync All" button.
Attached screenshots

Chosen solution

I have found the solution. On Huawei or Honor phones the option is difficult to find. The following path:

Settings > User&Accounts - here you can find individual apps, but it does not let you choose auto-sync settings directly. Go on this page to the three dots menu on the top left. Then you can tick auto-sync.

The battery improvement app suggests to deactivate auto-sync to save battery. I probably followed their advice, but could not find auto-sync in the settings search.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
943 solutions 7080 answers

Hi Castor

Are you signed into the same Firefox Account in both Firefox for Android and the other copy of Firefox you are using?

Hi Castor Are you signed into the same Firefox Account in both Firefox for Android and the other copy of Firefox you are using?
Was this helpful to you? 0
Quote

Question owner

Hi Seburo,

Yes, it is the same account. I managed to sync now using a shortcut in a seperate app (Elixir shortcuts). It seems I had maybe deactivated some basic auto-sync settings of my whole Android 9.1.0 Pie Huawei device. I am, however, still trying to find those basic settings now... without success.

PS: the screenshot section above is now syncing.

Hi Seburo, Yes, it is the same account. I managed to sync now using a shortcut in a seperate app (Elixir shortcuts). It seems I had maybe deactivated some basic auto-sync settings of my whole Android 9.1.0 Pie Huawei device. I am, however, still trying to find those basic settings now... without success. PS: the screenshot section above is now syncing.
Was this helpful to you?
Quote
uvix 2 solutions 15 answers

Hello castor, Seems your sync disabled in android settings.Android has separate settings.There is nothing you can do with firefox settings. 1) Go to android settings 2) Accounts and Backup 3) Accounts 4){firefox account name} 5) Sync account and enable it

Thank you

Hello castor, Seems your sync disabled in android settings.Android has separate settings.There is nothing you can do with firefox settings. 1) Go to android settings 2) Accounts and Backup 3) Accounts 4){firefox account name} 5) Sync account and enable it Thank you
Was this helpful to you?
Quote

Chosen Solution

I have found the solution. On Huawei or Honor phones the option is difficult to find. The following path:

Settings > User&Accounts - here you can find individual apps, but it does not let you choose auto-sync settings directly. Go on this page to the three dots menu on the top left. Then you can tick auto-sync.

The battery improvement app suggests to deactivate auto-sync to save battery. I probably followed their advice, but could not find auto-sync in the settings search.

I have found the solution. On Huawei or Honor phones the option is difficult to find. The following path: Settings > User&Accounts - here you can find individual apps, but it does not let you choose auto-sync settings directly. Go on this page to the three dots menu on the top left. Then you can tick auto-sync. The battery improvement app suggests to deactivate auto-sync to save battery. I probably followed their advice, but could not find auto-sync in the settings search.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.