X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Why is firefox showing 6 processes in my process list?

Posted

It's on an older machine but updating my hardware is not an option right now. I don't have this problem on any of my newer machines. I've been using firefox exclusiverly on multiple machines for more than 15 years and I have never had this or any issues until now.

It's on an older machine but updating my hardware is not an option right now. I don't have this problem on any of my newer machines. I've been using firefox exclusiverly on multiple machines for more than 15 years and I have never had this or any issues until now.
Quote

Additional System Details

Installed Plug-ins

Only what's installed by default

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

More Information

Eve
  • Top 25 Contributor
  • Administrator
60 solutions 385 answers

Helpful Reply

per this thread ( https://support.mozilla.org/en-US/questions/1183315 )

Hi, this is Multiprocess which is normal, but if you are having slowness/hanging issues, try reducing the number of multiprocesses: Go to Options > General - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to a smaller number - try 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

per this thread ( https://support.mozilla.org/en-US/questions/1183315 ) Hi, this is Multiprocess which is normal, but if you are having slowness/hanging issues, try reducing the number of multiprocesses: Go to Options > General - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to a smaller number - try 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.
Was this helpful to you? 1
Quote

Question owner

This is exactly what I needed. Thank you very much.

This is exactly what I needed. Thank you very much.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.