X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Firefox exits suddenly after couple minutes running on Win10 update 1903

Posted

After forced update to Windows 10 update 1903 Firefox does not run beyond 2 minutes. Firefox suddenly exits after about 3 minutes of running - regardless of what site I visit. Even exits if the browser has only 1 tab open to blank page. I can reproduce this problem every time I start firefox - even in Safe mode. Firefox always runs for around 3 minutes. Irrespective of what other application runs/or not. I don't see any crash reports too - when this happens. Last crash report I have was from before I noticed this problem. I have tried following and still see the issue (on Firefox 72 and now on 73 too. 64bit)

- disable all extensions
- restore to default theme
- run in safe mode
- refresh firefox
- uninstall and do a fresh install from scratch.

Any help is greatly appreciated. I could not even run Firefox long enough to post this message. Posting via Vivaldi browser.

After forced update to Windows 10 update 1903 Firefox does not run beyond 2 minutes. Firefox suddenly exits after about 3 minutes of running - regardless of what site I visit. Even exits if the browser has only 1 tab open to blank page. I can reproduce this problem every time I start firefox - even in Safe mode. Firefox always runs for around 3 minutes. Irrespective of what other application runs/or not. I don't see any crash reports too - when this happens. Last crash report I have was from before I noticed this problem. I have tried following and still see the issue (on Firefox 72 and now on 73 too. 64bit) - disable all extensions - restore to default theme - run in safe mode - refresh firefox - uninstall and do a fresh install from scratch. Any help is greatly appreciated. I could not even run Firefox long enough to post this message. Posting via Vivaldi browser.

Chosen solution

said

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Firefox just released an update.

Thanks! I no longer see the issue. However, I had to install update, refresh firefox, disable hardware acceleration and start adding add-ons one by one. So far I have ublock origin, multi-account containers. I haven't installed NoScript, Firefox dark theme, HTTPS everywhere extensions yet. But so far so good.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

Ublock Origin, NoScript, Multi-account containers, HTTPS everywhere, Firefox dark theme

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.107 Safari/537.36

More Information

Question owner

I forgot to mention, I tried running Firefox without hardware acceleration too, in vain.

I forgot to mention, I tried running Firefox without hardware acceleration too, in vain.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4385 solutions 61533 answers

Helpful Reply

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Firefox just released an update.
Was this helpful to you? 1
Quote

Chosen Solution

said

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Firefox just released an update.

Thanks! I no longer see the issue. However, I had to install update, refresh firefox, disable hardware acceleration and start adding add-ons one by one. So far I have ublock origin, multi-account containers. I haven't installed NoScript, Firefox dark theme, HTTPS everywhere extensions yet. But so far so good.

[[#answer-1291864|said]]'' <blockquote> https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Firefox just released an update. </blockquote> Thanks! I no longer see the issue. However, I had to install update, refresh firefox, disable hardware acceleration and start adding add-ons one by one. So far I have ublock origin, multi-account containers. I haven't installed NoScript, Firefox dark theme, HTTPS everywhere extensions yet. But so far so good.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.